DIY Port injection set up

Discussion in 'Mazdaspeed 3/6 Fuel, NOS, Meth, & Water Injection' started by Maisonvi, Jul 11, 2016.

Watchers:
36 users.
  1. Maisonvi

    Maisonvi Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    1,280
    Trophy Points:
    113
    Location:
    South Haven, MI
    Ratings:
    +1,693 / -0
    Originally I didnt have a return. Later iteration of the system included a return and a fuel pressure regulator

    Sent from my SM-G950U using Tapatalk
     
    Maisonvi, via a mobile device, May 29, 2018
    • Like Like x 1
  2. Mark Ringor

    Mark Ringor Greenie N00B Member

    Joined:
    Dec 11, 2018
    Posts:
    2
    Trophy Points:
    3
    Location:
    Australia
    Ratings:
    +4 / -0
    Sorry about the late post though i just completeld my return system using a walbro 460 lt per hr pump and it’s working fine. i just want to thanks everyone for their input which help me create mine.
     

    Attached Files:

    Mark Ringor, via an iPhone, Mar 14, 2019
    • Like Like x 3
  3. Maisonvi

    Maisonvi Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    1,280
    Trophy Points:
    113
    Location:
    South Haven, MI
    Ratings:
    +1,693 / -0
    Looks great. Glad it worked out
     
  4. anthony

    anthony Greenie Member

    Joined:
    Apr 28, 2016
    Posts:
    84
    Trophy Points:
    18
    Location:
    az
    Ratings:
    +59 / -1
    @Mark Ringor What are you using to hold the pump in?

    Also is it a unmodified basket since you don't have the ring that Mason made to sit inside the basket without the retainer?
     
    Last edited: Mar 14, 2019
  5. Mark Ringor

    Mark Ringor Greenie N00B Member

    Joined:
    Dec 11, 2018
    Posts:
    2
    Trophy Points:
    3
    Location:
    Australia
    Ratings:
    +4 / -0
    the actual walbro upper body is almost the same size as the oem pump. all i did is modify the fuel filter to suite the walbro pump. the filter doesn’t work now though, so i had to fit an external in line fuel filter.
    My FP starts at 48 psi and it shoots up to 83 psi as i boost up. what i found was the car rans smoother and the part throttle KR dropped dramatically. i don’t know if it’s related to a colder fuel due to the return
     
    Last edited: Mar 16, 2019
    Mark Ringor, via an iPhone, Mar 15, 2019
    • Like Like x 1
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)