Post S3 install thread because KiwiFail

Discussion in 'Mazdaspeed 3 Build Diaries' started by KiwiFlavor, Apr 25, 2017.

Watchers:
18 users.
  1. KiwiFlavor

    KiwiFlavor Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    951
    Trophy Points:
    93
    Location:
    Somersworth, NH
    Ratings:
    +1,229 / -3
    Yessir! It was such a good feeling! I slept so good last night!
     
    KiwiFlavor, via a mobile device, Jul 6, 2018
    • Like Like x 2
  2. KiwiFlavor

    KiwiFlavor Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    951
    Trophy Points:
    93
    Location:
    Somersworth, NH
    Ratings:
    +1,229 / -3

    Woot!!
     
    KiwiFlavor, via a mobile device, Jul 6, 2018
    • Like Like x 4
  3. Db09ms3

    Db09ms3 Silver Member

    Joined:
    Apr 20, 2017
    Posts:
    140
    Trophy Points:
    28
    Location:
    Phoenix AZ
    Ratings:
    +90 / -1
    Now that's the bees knees item 9 right there.
     
    • Like Like x 1
  4. KiwiFlavor

    KiwiFlavor Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    951
    Trophy Points:
    93
    Location:
    Somersworth, NH
    Ratings:
    +1,229 / -3
    Car is all buttoned up! Sorry not sorry for the potato pic lol!

    [​IMG]

    And these damn Moog endlinks... I’m stopping by Ace today either at lunch or otw home get some plug or a small bolt to replace the grease fitting.

    [​IMG]
     
    KiwiFlavor, via a mobile device, Jul 9, 2018
    • Like Like x 1
  5. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    968
    Trophy Points:
    93
    Location:
    Ontario, Canada
    Ratings:
    +718 / -3
    Moog end links were the death of me! I'll be going OEM next time. I now understand why some guys just keep OEM and replace them more frequently.



    Sent from my SM-N910W8 using Tapatalk
     
    Awafrican, via a mobile device, Jul 10, 2018
    • Like Like x 2
  6. Sho

    Sho Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    555
    Trophy Points:
    93
    Location:
    Akron, OH
    Ratings:
    +851 / -0
    100% agree. Oem only for me for the fronts at least. Rear links, I don't mind the moog
     
    Sho, via a mobile device, Jul 11, 2018
    • Like Like x 1
  7. Mauro_Penguin

    Mauro_Penguin Punk in Drublic Gold Member

    Joined:
    Feb 10, 2016
    Posts:
    659
    Trophy Points:
    93
    Location:
    Jacksonville, FL
    Ratings:
    +659 / -1
    What is the big hubbub about these moog front endlinks?

    I'd keep oem rears, aftermarket are not really worth the cost or benefit.
     
    Mauro_Penguin, via a mobile device, Jul 11, 2018
    • Like Like x 1
  8. SharksInSpace

    SharksInSpace Planets and shit. Silver Member

    Joined:
    Apr 5, 2016
    Posts:
    1,092
    Trophy Points:
    113
    Location:
    Middle Coast
    Ratings:
    +1,117 / -8
    I have Moog front and rear; no issues.
     
    • Like Like x 1
  9. KiwiFlavor

    KiwiFlavor Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    951
    Trophy Points:
    93
    Location:
    Somersworth, NH
    Ratings:
    +1,229 / -3
    For some reason the moogs that are on my gen2 are fine. But the zerk fitting rub the inner wall on my gen1. I found a pair of socket set screws to replace them tho. They are 1/4-28 x 1/4”. Couldnt find anything shorter at Ace.
     
    KiwiFlavor, via a mobile device, Jul 11, 2018
    • Like Like x 1
  10. Mauro_Penguin

    Mauro_Penguin Punk in Drublic Gold Member

    Joined:
    Feb 10, 2016
    Posts:
    659
    Trophy Points:
    93
    Location:
    Jacksonville, FL
    Ratings:
    +659 / -1
    Get some vice grips and remove that zerk fitting, find some small rubber plug for it and leave the fitting off until you need to grease them later on. Done deal.
     
    Mauro_Penguin, via a mobile device, Jul 11, 2018
    • Like Like x 1
  11. KiwiFlavor

    KiwiFlavor Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    951
    Trophy Points:
    93
    Location:
    Somersworth, NH
    Ratings:
    +1,229 / -3
    This is what I did

    [​IMG]
     
    KiwiFlavor, via a mobile device, Jul 11, 2018
    • Like Like x 2
  12. monkey.bones.007

    monkey.bones.007 Chuckin' sausage like a hooker rubs dick Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    2,513
    Trophy Points:
    113
    Location:
    80127
    Ratings:
    +2,802 / -3
    All I see is fail and no dildo...

    Tapatalk, it sucks for free!
     
    monkey.bones.007, via a mobile device, Jul 11, 2018
    • Like Like x 4
  13. SharksInSpace

    SharksInSpace Planets and shit. Silver Member

    Joined:
    Apr 5, 2016
    Posts:
    1,092
    Trophy Points:
    113
    Location:
    Middle Coast
    Ratings:
    +1,117 / -8
    I let mine snap off against the fender well because I didn't realize there was a clearance issue, then covered the hole with 3M automotive tape, lol. Working fine like that for 2+ years
     
    • Like Like x 2
  14. KiwiFlavor

    KiwiFlavor Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    951
    Trophy Points:
    93
    Location:
    Somersworth, NH
    Ratings:
    +1,229 / -3
    That’s what I read people did. But I just wanted it to be a little neat lol
     
    KiwiFlavor, via a mobile device, Jul 12, 2018
    • Like Like x 1
  15. KiwiFlavor

    KiwiFlavor Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    951
    Trophy Points:
    93
    Location:
    Somersworth, NH
    Ratings:
    +1,229 / -3
    A little update,

    Drove it to work about a week and a half ago and found there was a fuel leak and coolant leak. I had to borrow baking soda, a jug of water and my co-worker let me borrow a fire extinguisher from work to take home lol.

    Initially I thought the fuel leak was because of the o-rings at banjo fitting at the fuel rail but came to find out it was from the fuel pressure sensor not tightened down. #Kiwifail. Thankfully i could reach it from under the car without having to take the IM off. That would suck to take the JMF off...

    Coolant leak was at one of the hoses that goes from the coolant reservoir to the water housing.

    Did a short pull yesterday and saw I was boosting 25 PSI. popped the hood and had to write a note to myself: CLAMP THE DAMN EWG LINE! lol

    so far the car's been driven and in the process of break in for 117 miles approximately. Changed my oil at 50 miles, and will do another one at 150 miles. It pulls and drives nicely as far as I can tell. Can't wait for break in to be done and then tune for some powahhh!!
     
    • Like Like x 6
  16. monkey.bones.007

    monkey.bones.007 Chuckin' sausage like a hooker rubs dick Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    2,513
    Trophy Points:
    113
    Location:
    80127
    Ratings:
    +2,802 / -3
    I'm not saying I can see the future, but look back to my June 16th post... Glad you didn't burst into flames.

    Tapatalk, it sucks for free!
     
    monkey.bones.007, via a mobile device, Jul 23, 2018
    • Like Like x 2
  17. KiwiFlavor

    KiwiFlavor Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    951
    Trophy Points:
    93
    Location:
    Somersworth, NH
    Ratings:
    +1,229 / -3
    Why you put that evil on me???
     
    • Like Like x 1
  18. SharksInSpace

    SharksInSpace Planets and shit. Silver Member

    Joined:
    Apr 5, 2016
    Posts:
    1,092
    Trophy Points:
    113
    Location:
    Middle Coast
    Ratings:
    +1,117 / -8
    • Like Like x 2
  19. _Mazdarati

    _Mazdarati Silver Member

    Joined:
    Mar 13, 2017
    Posts:
    159
    Trophy Points:
    43
    Location:
    Dearborn, MI
    Ratings:
    +107 / -0
    Kiwi stop breaking your car
     
    • Like Like x 2
  20. KiwiFlavor

    KiwiFlavor Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    951
    Trophy Points:
    93
    Location:
    Somersworth, NH
    Ratings:
    +1,229 / -3
    Good day yesterday. Fixed my coolant leak and got on the dyno and sent it!

    Justin doing his magic and ended up with 371/360 on 20 psi and, if I heard right, 9* of timing. Solid number just on 93 gas.

    [​IMG]




    Sidebar:

    I think I just found my future wife. This girl I’ve been hanging out with helped me work on the car before I went to Freektune shop and took this pic.

    [​IMG]

    Whose man is this???
     
    KiwiFlavor, via a mobile device, Jul 26, 2018
    • Like Like x 2
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)