Super-Cheater K04

Discussion in 'Mazdaspeed 3/6 Engine' started by ConeKiller, Nov 30, 2016.

Watchers:
16 users.
  1. VTMongoose

    VTMongoose John/MD1032 Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    477
    Trophy Points:
    93
    Location:
    North Brunswick, NJ
    Ratings:
    +513 / -1
    Can you upload the map? You changed the "Max load limit" tables to a higher value than you log, right?

    edit: Also I suspect there is a problem with the chart function in VT because when I manually graph this log in excel, I don't get that really crazy looking choppiness in IDC that you do.

    Sent from my A0001 using Tapatalk
     
    Last edited: Jun 9, 2017
    VTMongoose, via a mobile device, Jun 9, 2017
    #21
    • Like Like x 1
  2. ConeKiller

    ConeKiller Motorhead Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    186
    Trophy Points:
    63
    Location:
    babytown, IL
    Ratings:
    +283 / -1
    Thanks.
    I'll upload the map this weekend.
    Yup, I believe I have all of the load tables adjusted up. It'll hit and maintain high 2.2/2.3 loads, but fueling is the issue.

    Good news on the graphing if the IDC's.

    FYI- Currently the car is on E-40 as an element of troubleshooting, but I'm planning on moving down to e15/e20 for the additional fueling headroom.
     
    ConeKiller, via a Nexus device, Jun 9, 2017
    #22
  3. ConeKiller

    ConeKiller Motorhead Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    186
    Trophy Points:
    63
    Location:
    babytown, IL
    Ratings:
    +283 / -1
    still seeing fueling not meeting targets, not sure why.
    I redid the map in a different OTS tune in versatune with 93 for the larges amount of fueling overheard possible.

    Not sure whats up- logs show WOT Fuel trimming still, and some random desired AFR's of 1.0/0.99 (car seems to ignore this).

    3 logs attached, with tune (zipped due to file extension issues).

    @Jason@DizzyTuning
     

    Attached Files:

  4. VTMongoose

    VTMongoose John/MD1032 Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    477
    Trophy Points:
    93
    Location:
    North Brunswick, NJ
    Ratings:
    +513 / -1
    Sorry, in the middle of a teardown on my own car...been busy. Should be able to take a look tonight. The table I was referring to is not listed under "load tables". It is called "Max Load Limit" A/B/C and is under "Closed Loop" tables in ATR. Default value is 2.5...you'll want to raise to 3.0 or higher. I wish I had VT on my work laptop so I could take a look at where it is in there. These might be it:

    http://www.mazdaspeedforums.org/forum/f573/closed-loop-load-limit-196104/
     
    • Like Like x 1
  5. ConeKiller

    ConeKiller Motorhead Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    186
    Trophy Points:
    63
    Location:
    babytown, IL
    Ratings:
    +283 / -1
    Thanks. I have played around with these tables a bit before in an effort to turn off the WOT/open loop trims, based on @Enki's thread , and they work in that regard.
    I'll cross-check, but I'm pretty sure these tables are already set to 3.0 load.

    I've ordered an ethanol mixture testing kit to get an definitive read on specific gravity, and I'll drop the closed loop load limits to see how accurate my MAFCAL actually is, and if adjusting it has any effect on the weird open loop fuel trims.

    FWIW- when I was initially troubleshooting this issue, I tried greatly increasing the MAFCAL past 3.5v (htp4") to force the car to richen the mixture- with no effect. It seems that the open loop trims have greater authority than I expected.
     
    • Like Like x 1
  6. Enki

    Enki Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    678
    Trophy Points:
    93
    Location:
    Tucson
    Ratings:
    +1,024 / -1
    They have a 20-25% limit, just like LTFT and STFT, if memory serves.
     
  7. VTMongoose

    VTMongoose John/MD1032 Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    477
    Trophy Points:
    93
    Location:
    North Brunswick, NJ
    Ratings:
    +513 / -1
    Hey man,

    Few things:

    1) The tables I was referring to are here, closed loop load limit. Need to make sure these tables are set above logged calculated load values, which they are, so you're in the clear:
    upload_2017-6-14_21-59-11.png

    2) You should set the "Open Loop WOT AFR Target Knock Present Extended" table the same as the other two WOT tables IMO. The ECU will enrichen the mixture on its own when knock is detected. No need to dump more fuel on top of that. This will prevent a lot of AFR wobbliness.

    3) You aren't missing targets by much. I think a MAF cal adjustment will get the job done. I do mine the lazy way...divide logged lambda by target lambda and multiply the corresponding MAF voltage cells by the resulting multiplier. I really don't see anything obviously wrong with the tune. Of course I'm also back to using Cobb again so finding the tables I'm interested in in VT is difficult and I probably forgot to check a few as a result.
     
  8. ConeKiller

    ConeKiller Motorhead Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    186
    Trophy Points:
    63
    Location:
    babytown, IL
    Ratings:
    +283 / -1

    Thanks,
    #1 - done
    #2 - done
    #3 - in the works.
     
  9. silvapain

    silvapain Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    60
    Trophy Points:
    33
    Location:
    Westmont, IL
    Ratings:
    +124 / -0
    silvapain, via a mobile device, Jun 15, 2017
    #29
    • Like Like x 3
  10. btstarcher

    btstarcher Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    124
    Trophy Points:
    28
    Location:
    Russellville, AR
    Ratings:
    +95 / -0
    Subbing, because I'm trying to keep everything as stock (looking) as possible.
     
  11. ConeKiller

    ConeKiller Motorhead Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    186
    Trophy Points:
    63
    Location:
    babytown, IL
    Ratings:
    +283 / -1
    Update time - super-cheater can haz 400hp

    except I just noticed in logs from about a month ago:
    brief/relevant mod list-
    SURE Intercooler, Autotechs, 4" htp intake, 3" catless DP

    [​IMG]

    For the sake of the rods and ringlands, the wgdc is going way down now that I've hit my self-imposed target power figure. That massive drop in power after the peak is due to the lean condition.

    I still haven't figured out the fueling issue, but I did stumble across this issue in a recent thread revival:

    http://www.mazdaspeedforums.org/forum/f426/post-spool-lean-condition-91610/index4.html

    Most notably, this nearly perfectly describes my problem:


    the proposed treatment is time- at this current moment I don't have a hardware or tuning fix for this, but most have reported that this goes away with time.
     
    • Like Like x 4
  12. JohnnyTightlips

    JohnnyTightlips Gold Member

    Joined:
    May 12, 2016
    Posts:
    379
    Trophy Points:
    63
    Location:
    Iowa
    Ratings:
    +316 / -0
  13. VTMongoose

    VTMongoose John/MD1032 Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    477
    Trophy Points:
    93
    Location:
    North Brunswick, NJ
    Ratings:
    +513 / -1
    I have a feeling this car died and went to speed6 heaven.
     
    • Like Like x 1
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)