The ButtStallion Build

Discussion in 'Mazdaspeed 3 Build Diaries' started by VashEXE, Oct 29, 2017.

Watchers:
16 users.
  1. Sho

    Sho Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    523
    Trophy Points:
    93
    Location:
    Akron, OH
    Ratings:
    +780 / -0
    I wouldn't worry about it. I can't fit a non low profile jack under my car and my oil pan has never contacted road surface. Most likely you're scraping the front lip on the bumper. You can see how much lower my speed is than my pu ( I can't fit a cigarette pack standin up between the ground and the bumper on the speed) .

    Anything that would damage the pan, would have to be sticking up from the road a good bit

    20180805_175423-01.jpeg
     
    Sho, via a mobile device, Aug 14, 2018
    #81
    • Like Like x 1
  2. SharksInSpace

    SharksInSpace Planets and shit. Silver Member

    Joined:
    Apr 5, 2016
    Posts:
    1,050
    Trophy Points:
    113
    Location:
    Middle Coast
    Ratings:
    +1,044 / -3
    99% you're hitting the bumper. They sound disproportionately gnarly when they drag.
     
  3. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    So a bit of an update.

    I got the rear suspension all wrapped up finally. My buddy came over and we got the split second controller all soldered and connected as well. I had my harness tucked by Eric and had the PI dongle added on as well. Got the dongle soldered onto the yellow/black wires for the coil signals and also got the power (using the moonroof fuse slot with an add a fuse), ground (bolted on top of one of the existing grounds behind the drivers side headlight), and the MAF V wire.

    I fired up the car after hooking everything up and after backing out of the driveway the car stalled and died. Doesn't start anymore... After pushing it up into the driveway as much as I could (steep as fuck) I checked the codes. Basically a bunch of stuff on the harness where the PI dongle was at (evap, app, fuel pressure regulator, etc). Did some googling and ended up finding a couple things. My injector fuse was blown out. Swapped that and the car started, but still wouldn't run right. Had to unplug the battery for a bit to reset the app and then it fired up and ran like a champ. I have the PI injectors, split second dongle to the coils, and the add a fuse for SS power unplugged currently and the car is running normal. I guess the next step is gonna be plugging them in one at a time and figuring out which is blowing out my injector fuse. It seems like a short, but I know Eric does good work, so I'm not really sure where my issue lies yet.

    Fun times with electrical.

    [​IMG]
     
    • Like Like x 2
  4. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    Haven't done any further troubleshooting on the SS stuff yet, but my AP decided to throw a fatal error last night while driving and showed a crazy rainbow screen. Before my AP dies completely I ordered the V2 to V3 upgrade and I'll be un-marrying it asap to send it back to ol' Cobb. I was really torn between a V3 and Versatuner, but I really just don't want to have to deal with a laptop or a Windows tablet whenever I want to do my tuning. I like the ease of having a little device specifically for logging and whatnot. Monitoring multiple things will be nice for tuning since I'm restarting the whole tune anyways, so it's a blessing and a curse haha.
     
  5. Sho

    Sho Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    523
    Trophy Points:
    93
    Location:
    Akron, OH
    Ratings:
    +780 / -0
    I hate to say it, but I Fucking hate wire tuck harnesses. Every person I know locally that runs one, whether from Eric or anyone else has always had electrical issues. Haven't seen a single one locally that didn't start throwing random codes after install, or start popping fuses, or causing the car to run like shit
     
    Sho, via a mobile device, Aug 15, 2018
    #85
    • Like Like x 1
  6. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    Don't tell me that. :(

    I'm hoping that's not the case, but we'll see. No matter what I'm going to have to tap into the coil signal wires, but I don't even necessarily need the tuck. I'm top mount so I don't see any of that shit, I really just wanted it for the nice PI dongle and a little cleanup.
     
  7. Solarsurge

    Solarsurge Gold Member

    Joined:
    Jun 9, 2018
    Posts:
    169
    Trophy Points:
    43
    Location:
    Richmond, VA
    Ratings:
    +191 / -0
    Cleaned the memory on your AP up real quick lol

    I kid... I kid... :D


    Sent from my iPhone using Tapatalk
     
    Solarsurge, via a mobile device, Aug 15, 2018
    #87
  8. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    Been a while since my last update.

    I got my AP V3 last night. Pretty nice looking piece. Did all of the freaking EFI U stuff to get AccessTuner again. Luckily Cobb gave me a discount code to waive the fee after I complained on the phone. I was surprised how long the course took honestly. Has some cool information and has the Australian guy from Haltech that is on Mighty Car Mods occasionally in all of the videos. Finished it all and got Accesstuner, so tonight I'm gonna get my basemap set up on Accesstuner and flashed onto my car from the V3.

    I also need to get my SplitSecond controller flashed. My Windows 8.1 laptop isn't super happy about connecting to the SplitSecond controller with the R4 software. When I click connect, it'll connect, but when I try to flash data it says there's a communication error. I've disabled USB3.0 and have been running in 2.0 mode, etc., but still no dice. I'm going to get a Win7 VM set up and see where I can get from there.

    Hopefully I can start getting some stuff dialed in soon!
     
  9. mangosmoothie

    mangosmoothie Platinum Member

    Joined:
    Sep 14, 2016
    Posts:
    185
    Trophy Points:
    43
    Location:
    STL
    Ratings:
    +183 / -1
    I did not like the cobb course. I guess there's decent info there, but it doesn't tell me much the table descriptions don't. The beginning videos about injector sizing didn't apply. I felt like I learned more reading the tuning manual on MSF someone made and reading versatune table descriptions. Maybe I should go back and watch the cobb vids again
     
  10. Solarsurge

    Solarsurge Gold Member

    Joined:
    Jun 9, 2018
    Posts:
    169
    Trophy Points:
    43
    Location:
    Richmond, VA
    Ratings:
    +191 / -0
    While I probably could tune my own car, I don’t solely based on the fundamental understanding that my best job on my best day probably would still not be as good as my tuner’s laziest effort on a day he doesn’t want to work. I’d rather spend my time and energy on the things I do well and let him do his job lol


    Sent from my iPhone using Tapatalk
     
    Solarsurge, via a mobile device, Aug 22, 2018
    #90
    • Like Like x 2
  11. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    Yeah a lot of stuff didn't apply, but I'm always down to learn a little more about other platforms and the differences in tuning processes. The guy also said that the Mazda 3 was called the Alexia (Axela) in Japan and repeated it a few times, so I was laughing a little at that. There was some goofy stuff in there, but it was a decent watch. Some stuff I never even bothered to question or learn since it wasn't applicable to the mazdaspeed platform.

    Learning to tune your own ride makes troubleshooting stuff so much easier. It's nice to be able to open up your map and see what you're targeting and crosscheck it with what you're logging. To be honest, there isn't really THAT much to tuning. Lots of people joke about it, but it really is mainly MAFCAL.
     
  12. Solarsurge

    Solarsurge Gold Member

    Joined:
    Jun 9, 2018
    Posts:
    169
    Trophy Points:
    43
    Location:
    Richmond, VA
    Ratings:
    +191 / -0
    Maybe for stock setups, but when you start adding aux fueling and modifying the head and what not... it gets real complicated real quick to the point a dumb mistake can cause catastrophic failures real quick. That’s a little out of my league haha


    Sent from my iPhone using Tapatalk
     
    Solarsurge, via a mobile device, Aug 22, 2018
    #92
  13. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    Lol 6th port and methanol setups for extra fuel is just adjusting your mafcal as well! It's not as complicated as you think man!
     
    • Like Like x 1
  14. Solarsurge

    Solarsurge Gold Member

    Joined:
    Jun 9, 2018
    Posts:
    169
    Trophy Points:
    43
    Location:
    Richmond, VA
    Ratings:
    +191 / -0
    I’m full PI + Meth for cooling lol.


    Sent from my iPhone using Tapatalk
     
    Solarsurge, via a mobile device, Aug 22, 2018
    #94
  15. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    Yeah, so you'll dial in your PI first and then disable your open loop trimming and add in the meth after everything else. If you were running both at the same time it'd be hard to dial in the PI so that you weren't accidentally using some of the meth as fuel. In reality my 6th port tuning and your PI + cooling meth tuning isn't really all that different. That's a lot of fuel man haha.
     
  16. Solarsurge

    Solarsurge Gold Member

    Joined:
    Jun 9, 2018
    Posts:
    169
    Trophy Points:
    43
    Location:
    Richmond, VA
    Ratings:
    +191 / -0
    I’d rather have it and not necessarily need it now than need it later and have to totally redesign the fuel system again. :p


    Sent from my iPhone using Tapatalk
     
    Solarsurge, via a mobile device, Aug 22, 2018
    #96
  17. Sho

    Sho Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    523
    Trophy Points:
    93
    Location:
    Akron, OH
    Ratings:
    +780 / -0
    The r4 software will not flash to the ssc controller if you dont have the right cable. Grab the 1.3 foot insignia serial cable form best buy and give that a whirl
     
    Sho, via a mobile device, Aug 22, 2018
    #97
    • Like Like x 1
  18. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    So I was swapping over to the V3 tonight. Got the V2 unmarried and after that I tried to marry up the V3. Kept giving me an error saying it cannot connect with the ECU. Immobilizer light is flashing. Car won't try to crank (though it wouldn't work anyways with stock tune). Can't get either AP to detect the ECU anymore. Checked a bunch of fuses and they're all good. Removed all extra electrical shit, although it was all working with the car before. Not sure what the fuck I need to do at this point. Pretty frustrated. Will call Cobb tomorrow and see what they say...
    --- Double Post Merged, Aug 23, 2018 ---
    After a bunch of troubleshooting and swearing last night it's looking like even though the V2 accessport uninstalled and showed the green checkmark for the completed uninstall process, something must've fucked up during the process. Neither AP can communicate with the ECU at this point and I've tried new cables, checked all fuses, removed any new electrical stuff, unplugged ECU and battery, checked OBD pins, and tested the battery.

    Talked with Cobb and they say they can probably repair it. They're going to try to flash the stock rom onto the ECU and they'll also verify that both APs are functioning and I won't be screwed when I get it all back. Pretty cheap and I'm glad they offer it, but it's a pain in the ass that I have to ship all this shit out.

    Nothing is ever easy.
     
  19. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    Just got an email back from Cobb. They said that they've processed my V3 upgrade and have also finished the repairs on the ECU. Invoice is paid and they're going to overnight it all back to me. Here's to hoping that it'll all just marry up and work when I get it later this week...



    I'll get that cable and give it a shot for sure. I got one on Amazon that others were saying worked for them, but who knows. These serial to USB adapters are always flakey. If that doesn't work I'll just get a Win7 VM set up on the laptop or maybe just install it directly and try again.
     
    • Like Like x 1
  20. VashEXE

    VashEXE Silver Member

    Joined:
    Feb 25, 2016
    Posts:
    259
    Trophy Points:
    63
    Location:
    Arizona
    Ratings:
    +333 / -3
    The ECU and AP are at my house again. Great turnaround time. Got there Friday and was finished/shipped Monday. Cost me a total of $205 to over night ship it both ways as well as the $80 labor that Cobb charged me. Hopefully everything is working normally after all of this. The one thing I'm not sure about is the keys. I feel like I might need to have them reprogrammed, so I might end up having to go to the dealership anyways, but we'll see.
    --- Double Post Merged, Aug 28, 2018 ---
    The ECU is fixed and the V3 is married. We're back up and running boys!

    Split second will still not connect properly to the laptop even with the Insignia cable that @Sho recommended, but I've read lots of issues with Win8 and this, so I'm gonna go ahead and see if 10 will fix it since I can install that quickly. If not, I'll blow the laptop away and get 7 on it. Fun times.
     
    • Like Like x 5
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)