The fail continues.....

Discussion in 'Mazdaspeed 3 General Discussion' started by btstarcher, Mar 15, 2017.

Watchers:
7 users.
  1. btstarcher

    btstarcher Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    57
    Trophy Points:
    18
    Location:
    Russellville, AR
    Ratings:
    +35 / -0
    [​IMG]How the fuck does this even happen? It looks like my fail may have followed me to the pu after all.

    And no, it's not disconnected. The whole connector broke off of the throttle body.

    Sent from my HTC6545LVW using Tapatalk
     
    btstarcher, via a mobile device, Mar 15, 2017
    #1
  2. Darthxar

    Darthxar Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    684
    Trophy Points:
    93
    Location:
    Marseilles, IL
    Ratings:
    +500 / -0
    Holy shit, I don't think I've ever seen that happen. I've had some connecter issues on my PU, but that's a new level.

    Sent from my XT1575 using Tapatalk
     
    Darthxar, via a mobile device, Mar 15, 2017
    #2
  3. btstarcher

    btstarcher Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    57
    Trophy Points:
    18
    Location:
    Russellville, AR
    Ratings:
    +35 / -0
    Well I hit a medium sized dog. Fucked must have reached up in his final act for one last "fuck you" and ripped off the harness. Bastard.

    Sent from my HTC6545LVW using Tapatalk
     
    btstarcher, via a mobile device, Mar 15, 2017
    #3
  4. Darthxar

    Darthxar Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    684
    Trophy Points:
    93
    Location:
    Marseilles, IL
    Ratings:
    +500 / -0
    Damn, what are the odds?

    Sent from my XT1575 using Tapatalk
     
    Darthxar, via a mobile device, Mar 15, 2017
    #4
    • Like Like x 1
  5. btstarcher

    btstarcher Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    57
    Trophy Points:
    18
    Location:
    Russellville, AR
    Ratings:
    +35 / -0
    I've learned to never ask that question.

    Sent from my HTC6545LVW using Tapatalk
     
    btstarcher, via a mobile device, Mar 15, 2017
    #5
  6. Maisonvi

    Maisonvi Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    790
    Trophy Points:
    93
    Location:
    South Haven, MI
    Ratings:
    +889 / -0
    I have a old broken TB in the same spot. No idea how it was broken though, I got it that way on a spare motor. Sucks man. Tell CS you want one of their new fancy ones
     
    • Like Like x 4
  7. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    781
    Trophy Points:
    93
    Location:
    Ontario, Canada
    Ratings:
    +500 / -2
    That's balls man
     
    Awafrican, via a mobile device, Mar 16, 2017
    #7
  8. udntknw

    udntknw Gold Member

    Joined:
    Feb 10, 2016
    Posts:
    28
    Trophy Points:
    3
    Location:
    Tucson, AZ
    Ratings:
    +15 / -0
    I got my car back from Mazda after they did the VVT actuator TSB in 09, didn't realize it until a while later that I had a ziptie holding my throttle body connector together. I'm guessing they pulled on the harness during disassembly not realizing it went down to the throttle body.

    Sent from my HTC6535LVW using Tapatalk
     
    udntknw, via a mobile device, Mar 18, 2017
    #8
    • Like Like x 1
  9. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    781
    Trophy Points:
    93
    Location:
    Ontario, Canada
    Ratings:
    +500 / -2
    Hmm they gonna replace it then?
     
    Awafrican, via a mobile device, Mar 18, 2017
    #9
  10. btstarcher

    btstarcher Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    57
    Trophy Points:
    18
    Location:
    Russellville, AR
    Ratings:
    +35 / -0
    I decided to claim it on my insurance. With the TB broken, I'll be able to cover my deductible and just replace it with my old one.

    Sent from my HTC6545LVW using Tapatalk
     
    btstarcher, via a mobile device, Mar 18, 2017
    #10
  11. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    781
    Trophy Points:
    93
    Location:
    Ontario, Canada
    Ratings:
    +500 / -2
    Ah well that's something then
     
    Awafrican, via a mobile device, Mar 18, 2017
    #11
  12. btstarcher

    btstarcher Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    57
    Trophy Points:
    18
    Location:
    Russellville, AR
    Ratings:
    +35 / -0
    Yeah the bumper is broken, and the undertray is torn up, splash guards missing, etc. I've hit 3 or 4 animals now, and it's time to get it fixed.

    Sent from my HTC6545LVW using Tapatalk
     
    btstarcher, via a mobile device, Mar 18, 2017
    #12
  13. deltapsik0

    deltapsik0 Greenie Member

    Joined:
    Feb 25, 2017
    Posts:
    22
    Trophy Points:
    3
    Location:
    Bay Area
    Ratings:
    +9 / -0
    I never swerve either .. fuck dying


    Sent from my iPhone using Tapatalk
     
    deltapsik0, via a mobile device, Mar 18, 2017
    #13
    • Like Like x 2
  14. macdiesel

    macdiesel Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    76
    Trophy Points:
    18
    Location:
    Chicago
    Ratings:
    +52 / -0
    macdiesel, via an iPad, Mar 19, 2017
    #14
  15. djohns

    djohns Silver Member

    Joined:
    Feb 17, 2016
    Posts:
    289
    Trophy Points:
    63
    Location:
    Plainfield Il
    Ratings:
    +251 / -0
    IMG_6109.PNG Jesus Christ man. Where the fuck do you live you're hitting all these animals? Are you fucking zoo keeper or something? Is this an actual photo?
     
    djohns, via an iPhone, Mar 20, 2017
    #15
    • Like Like x 2
  16. btstarcher

    btstarcher Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    57
    Trophy Points:
    18
    Location:
    Russellville, AR
    Ratings:
    +35 / -0
    I drive a lot, approx. 70k miles per year. I also work a 12-hour shift, so I'm driving early in the morning, leaving around 4am. I often visit my son, driving back late at night. Arkansas highways. I usually hit raccoons and dogs, sometimes possums but they don't do much damage. Damn raccoons are the size of a medium size dog around here.

    I took my "extra" throttle body to the shop and looked at the damage. Apparently the A/C condenser and radiator are both bent, but not broken. The cooling fans are both broken, and so is the "core support" (if you can call it that; just a plastic piece that holds the radiator in place). When the fans broke that piece contacted the throttle body and broke it. This is easily going to exceed my deductible.
     
    • Like Like x 1
  17. Darthxar

    Darthxar Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    684
    Trophy Points:
    93
    Location:
    Marseilles, IL
    Ratings:
    +500 / -0
    70k a year? Damn man, I only have 63k on my 4 year old daily PU.

    Sent from my XT1575 using Tapatalk
     
    Darthxar, via a mobile device, Mar 25, 2017 at 10:04 PM
    #17
    • Like Like x 1
  18. btstarcher

    btstarcher Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    57
    Trophy Points:
    18
    Location:
    Russellville, AR
    Ratings:
    +35 / -0
    I bought mine with 13500 on it in November 2015, it's over 105k now.

    Sent from my HTC6545LVW using Tapatalk
     
    btstarcher, via a mobile device, Mar 25, 2017 at 10:10 PM
    #18
  19. Darthxar

    Darthxar Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    684
    Trophy Points:
    93
    Location:
    Marseilles, IL
    Ratings:
    +500 / -0
    Wow

    Sent from my XT1575 using Tapatalk
     
    Darthxar, via a mobile device, Mar 25, 2017 at 10:21 PM
    #19
    • Like Like x 3
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)