Recent Activity

Activity stream for all registered members at Mazdaspeeds.org, The New Era in Mazdaspeed, CX-7 & Ecoboost Forums!.

  1. GohanX replied to the thread Bucking underload and moving misfire.

    I believe the blow test only shows you that a valve is bad, not necessarily if it was good or not. If it has failed, you might be able...

    Sep 17, 2020 at 11:35 PM
  2. Mauro_Penguin liked KiwiFlavor's post in the thread Post S3 install thread because KiwiFail.

    The replacement o-ring looked good when I swapped out mine with my buddy’s MAF and we knew his was good. I will be getting an o-ring...

    Sep 17, 2020 at 10:36 PM
  3. sacredmonkey92 attached a file to the thread Starts sometimes, wont start other times???.

    here is a log of it cranking and failing to start. For some reason I think the battery might have something to do with it. Low voltage...

    Sep 17, 2020 at 10:22 PM
  4. 2008ms3nick replied to the thread Bucking underload and moving misfire.

    Test it like on the vehicle? Of course I’ll make the instal tomorrow I was just confused on the valve because it was mentioned I should...

    Sep 17, 2020 at 9:40 PM
  5. 2008ms3nick replied to the thread Bucking underload and moving misfire.

    So I just got the new pressure relief valve in today and I’m checking it to see if I can blow air through it and I can’t blow through...

    Sep 17, 2020 at 9:10 PM
  6. Ssinstaller replied to the thread Low level output from amp.

    Terminals b7-B10 can be used for your rca connections, b11 should be fine for remote.

    Sep 17, 2020 at 8:35 PM
  7. sacredmonkey92 replied to the thread Starts sometimes, wont start other times???.

    I just noticed my battery when I turn the car over is at 10 volts.

    Sep 17, 2020 at 8:27 PM
  8. sacredmonkey92 attached a file to the thread Starts sometimes, wont start other times???.

    I think I uploaded my datalog, sorry there's so much info on it I wanted to see everything that was happening. So at first the car...

    Sep 17, 2020 at 8:04 PM
  9. KiwiFlavor replied to the thread Post S3 install thread because KiwiFail.

    The replacement o-ring looked good when I swapped out mine with my buddy’s MAF and we knew his was good. I will be getting an o-ring...

    Sep 17, 2020 at 7:29 PM
  10. KiwiFlavor liked SharksInSpace's post in the thread Post S3 install thread because KiwiFail.

    back f i r e

    Sep 17, 2020 at 7:21 PM
  11. KiwiFlavor liked Awafrican's post in the thread Post S3 install thread because KiwiFail.

    Wtf happened to your throttle body that it got bent? Your turbo take a shit?

    Sep 17, 2020 at 7:21 PM
  12. Jok’air replied to the thread injection duty cyle maxed.

    yes the complete rail and injector changed by those of a car which I was on operation

    Sep 17, 2020 at 7:16 PM
  13. Mxer4life replied to the thread How many miles on your MS3.

    1) 2010 2) 130,000 miles purchased at 99,862.8 (only remember the exact because it barely passed for the loan lol) 3) Just rebuilt the...

    Sep 17, 2020 at 4:45 PM
  14. Mauro_Penguin liked KiwiFlavor's post in the thread Post S3 install thread because KiwiFail.

    Hello hello, figured I’d give some updates. I’m just going to upload some random images with a description lol! The bent TB: [IMG]...

    Sep 17, 2020 at 4:39 PM
Loading...