Burning shit tonight of oil

Discussion in 'Mazdaspeed 3 Troubleshooting' started by Speed27, Oct 13, 2021 at 3:13 AM.

Watchers:
4 users.
  1. Speed27

    Speed27 Greenie Member

    Joined:
    Sep 10, 2021
    Posts:
    12
    Trophy Points:
    3
    Location:
    Georgia
    Ratings:
    +3 / -0
    So I have a mazdaspeed 3 2007 with 132000 miles so what happening to me is I just changed out 1 injector which was always open and after 20 miles my car started to smoke suddenly like the car was on fire and after 20 miles of driving I lost more than 3 quarts of oil before that it was burning no oil really need some help
     
    Speed27, via a mobile device, Oct 13, 2021 at 3:13 AM
    #1
  2. jdab555

    jdab555 Greenie Member

    Joined:
    Mar 11, 2020
    Posts:
    68
    Trophy Points:
    18
    Location:
    22801
    Ratings:
    +32 / -0
    Did you replace it with a cleaned / tested OEM injector that has new o-rings and seal?

    If it was running fine before, sounds like something got unplugged, left un-attached, or similar. Could be an oil line came off, possibly near the oil filter if you were messing around near there, or a coincidental oil feed line breakage near the turbo. Have you looked under the car to find out where it lost the oil?
     
  3. JohnnyTightlips

    JohnnyTightlips Motorhead Silver Member

    Joined:
    May 12, 2016
    Posts:
    1,411
    Trophy Points:
    113
    Location:
    Iowa
    Ratings:
    +2,132 / -0
    3 quarts in 20 miles is a TON, the car would drive like total garbage if it was burning that much. It is likely there is a leak somewhere and it is just puking it out.
     
  4. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    5,971
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +7,008 / -8
    All injectors probably were leaking and new/rebuilt injectors plus $200+ in o rings on them plus a set of Corksport injector seals is how I would have done it. Wait. I actually did it. But you have a massive leak. Time to go underneath and look at everything
     
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)