street car gone road race

Discussion in 'Mazdaspeed 3 Build Diaries' started by gotovato, Aug 13, 2018.

?

Which wheels for my car?

  1. Polished lip

    5 vote(s)
    38.5%
  2. Matte grey

    8 vote(s)
    61.5%
Watchers:
41 users.
  1. L337TurboZ

    L337TurboZ Master Technician Silver Member

    Joined:
    Jun 15, 2020
    Posts:
    420
    Trophy Points:
    63
    Location:
    Charleston, South Carolina USA
    Ratings:
    +394 / -4
    I would still check it with a gauge. Is the engine knocking? Maybe the pressure relief valve in the oil pump stuck open?
     
    Last edited: Jul 28, 2021
    L337TurboZ, via a Motorola device, Jul 28, 2021
    • Like Like x 1
  2. gotovato

    gotovato Silver Member

    Joined:
    May 29, 2018
    Posts:
    632
    Trophy Points:
    93
    Location:
    Mississauga, Ontario
    Ratings:
    +797 / -0
    Pump is 2 months old. I can’t believe it would’ve failed.

    cylinder 3 rod bearing. Nothing here catches any nail,
    4F86DC19-D21E-4F97-BA3F-7B7FFD4D38B5.jpeg
    7792A2A8-1C42-4B03-8671-E4BB1CF2BCFE.jpeg
     
    gotovato, via an iPhone, Jul 28, 2021
  3. gotovato

    gotovato Silver Member

    Joined:
    May 29, 2018
    Posts:
    632
    Trophy Points:
    93
    Location:
    Mississauga, Ontario
    Ratings:
    +797 / -0
    Well...

    THE CAR FUCKING WORKS. MOTOR IS ALIVEEEEEE WITH A STRONG 80psi cold start

    my buddy came by and did some Houdini shit. We know what caused this. I’ll update here in a bit but holy fuck man. Motor sounds fantastic too. We’re gonna do all new rod bearings next week just to be safe but yea fucking right!!!!!! Woooooo!!!!!! I honestly cannot believe it. The trouble shooting my buddy came up with. Next level. Definitely a good guy to know.
     
    gotovato, via an iPhone, Jul 28, 2021
    • Like Like x 6
  4. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,811
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +2,340 / -13
    Wtf man you can't leave me with blue balls like that. What was the issue!?!?!
     
    Easter Bunny, via a mobile device, Jul 28, 2021
    • Like Like x 7
  5. jdab555

    jdab555 Greenie Member

    Joined:
    Mar 11, 2020
    Posts:
    63
    Trophy Points:
    18
    Location:
    22801
    Ratings:
    +32 / -0
    Sometimes emotions get the better of us with car stuff - thinking logically (and hearing the motor) it definitely didn't sound catastrophic. Pumped it works!
     
    • Like Like x 2
  6. Awafrican

    Awafrican Moderator Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    2,472
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,871 / -7
    Right?! What a cock tease.

    Glad she's running though
     
    Awafrican, via a mobile device, Jul 28, 2021
    • Like Like x 3
  7. SyntheticAtmosphere

    SyntheticAtmosphere Its not illegal if your good at it! Silver Member

    Joined:
    Aug 1, 2016
    Posts:
    120
    Trophy Points:
    43
    Location:
    Canada
    Ratings:
    +126 / -0
    Glad to hear things are back on track!

    Sent from my SM-G930W8 using Tapatalk
     
    SyntheticAtmosphere, via a mobile device, Jul 28, 2021
    • Like Like x 1
  8. StreetSpeed6

    StreetSpeed6 Diesel Slayer Silver Member

    Joined:
    Mar 1, 2018
    Posts:
    784
    Trophy Points:
    93
    Location:
    Indiana
    Ratings:
    +535 / -1
    Well get on with it man, TELL US lol
     
    StreetSpeed6, via a mobile device, Jul 28, 2021
    • Like Like x 1
  9. gotovato

    gotovato Silver Member

    Joined:
    May 29, 2018
    Posts:
    632
    Trophy Points:
    93
    Location:
    Mississauga, Ontario
    Ratings:
    +797 / -0
    This is like...gonna be a wall of text.

    my buddy thought of some good trouble shooting. First off we put the pan back on. Filled oil. Removed the oil filter. We also removed spark plugs and I primed the engine foot floored on accelerator.

    Nothing coming out of the filter housing. Not a drop. Pump isn’t sucking anything up. Ok...
    my buddy knowing me from my srt4 days knew I probably had Lucas oil around. We used that shit for everything in the neon days. Mostly to quiet piston slap since it was just a neon thing. I had an almost full bottle.

    He crammed my oil pump full. Filled the pick up tube. Put it all back together. Pan on. Oil filled. Filter off.

    I primed the engine again cranking cranking. This time.

    STOP STOP STOP. oil SHOOOOOOOTING out of the filter housing. About 1 liter in 2 seconds of cranking. Well. Fuck. That’s good. Oil filter back on. Primed the engine some more. Saw 1psi. Oh fuck. Ok plugs back in. Crank crank crank. Fire it up.

    2psi, 15psi...directly to 80psi clean idle sounding fucking fantastic. That’s it. We’re good.

    We’re going to do the rod bearings just because why not so I just ordered some king race bearings.

    Theory is the cooked to fuck oil I drained out of the car for 30 minutes caused the oil pump to lose its prime. That’s the best theory we got. We played with the old oil. It wouldn’t even stay on your finger just falls off like water. 0w20 I had for the GFs car even used was thicker then that. I guess I cooked the fuck out of the oil plus high rpm.

    this our theory. It’s all we got.
     
    gotovato, via an iPhone, Jul 29, 2021
    • Like Like x 5
  10. Kraze

    Kraze Silver Member

    Joined:
    Jan 18, 2021
    Posts:
    61
    Trophy Points:
    18
    Location:
    North Idaho
    Ratings:
    +51 / -0
    Well I'll be damned. Definitely not what I would have guessed, but I'm glad it was still something relatively simple! Happy to hear it's back up and running.
     
    • Like Like x 1
  11. gotovato

    gotovato Silver Member

    Joined:
    May 29, 2018
    Posts:
    632
    Trophy Points:
    93
    Location:
    Mississauga, Ontario
    Ratings:
    +797 / -0
    yea man honestly. wouldve never ever guess this and if my buddy didnt come by with his "we're not going out like this" attitude i wouldve called it a day and motor would be coming out. crazy right
     
  12. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,811
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +2,340 / -13
    Wait the oil pumps aren't self priming?

    So I guess you will be running straight 50 on the track now
     
    Easter Bunny, via a mobile device, Jul 29, 2021
  13. gotovato

    gotovato Silver Member

    Joined:
    May 29, 2018
    Posts:
    632
    Trophy Points:
    93
    Location:
    Mississauga, Ontario
    Ratings:
    +797 / -0
    So these pumps being positive displacement they are difficult to prime if you lose the prime. Oil pumps don’t create pressure that comes from the oil being squeezed everywhere. If the pump is sucking up air, there’s no seal on the pick up point and that’s it. Our theory is just the oil was so cooked, and I drained it for so long the pump just lost its prime.

    when my oil cooler goes back on this won’t be an issue again. It was never an issue when I was running my stock block. That said I never revved it as hard and it wasn’t making this power. High temp + high rpm is like oil killer to the max. I’m going to send a sample of my cooked oil to Blackstone but it’s like water thin so that tells me something.
     
    gotovato, via an iPhone, Jul 29, 2021
    • Like Like x 2
  14. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,811
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +2,340 / -13
    I learned something today I had always assumed that oil pumps in cars were able to prime themselves
     
    Easter Bunny, via a mobile device, Jul 29, 2021
    • Like Like x 1
  15. gotovato

    gotovato Silver Member

    Joined:
    May 29, 2018
    Posts:
    632
    Trophy Points:
    93
    Location:
    Mississauga, Ontario
    Ratings:
    +797 / -0
    Me and my buddy learned this as well. If you Google a bit, v8 guys are HUGE on priming fresh builds. It’s like a die hard thing they do. Pump works the same way soooo I guess that’s what it is? It’s always suggested on a brand new build to pack the oil pump with grease/ vaseline. I guess this is the theory behind it? Not 100% sure.
    I did learn a shit load going through this.

    seeing how clean that motor is and how clean the bearing was...we knew something fucky was going on.
     
    gotovato, via an iPhone, Jul 29, 2021
    • Like Like x 2
  16. JohnnyTightlips

    JohnnyTightlips Motorhead Silver Member

    Joined:
    May 12, 2016
    Posts:
    1,395
    Trophy Points:
    113
    Location:
    Iowa
    Ratings:
    +2,088 / -0
    I did see a youtube episode where they had issues with an Evo not wanting to make any oil pressure on a fresh build, the fix ended up being to prime the oil pump. Sounds like it was not super common but has happened from time to time. I had no issues on my engine build with a fresh pump but I guess you never know. Glad you got it sorted.
     
    • Like Like x 2
  17. gotovato

    gotovato Silver Member

    Joined:
    May 29, 2018
    Posts:
    632
    Trophy Points:
    93
    Location:
    Mississauga, Ontario
    Ratings:
    +797 / -0
    Yea. I’m not the first and won’t be the last. Maybe the first on this platform but being realistic...any shop would’ve told me “you need a motor” so how often is that the answer vs TRY EVERYTHING AND ANYTHING.
     
    gotovato, via an iPhone, Jul 29, 2021
    • Like Like x 3
  18. dudemancool1904

    dudemancool1904 Greenie Member

    Joined:
    Feb 27, 2020
    Posts:
    21
    Trophy Points:
    3
    Location:
    San Diego
    Ratings:
    +22 / -1
    not surprised. even with modern lubricants your temps gotta be cooking the juice. glad it's back!
     
    • Like Like x 1
  19. gotovato

    gotovato Silver Member

    Joined:
    May 29, 2018
    Posts:
    632
    Trophy Points:
    93
    Location:
    Mississauga, Ontario
    Ratings:
    +797 / -0
    Small updated.

    Fresh bearings have arrived. Exactly how I like my metal. Black.
    04222BCB-BC78-4594-8495-8E8CB1F9D659.jpeg

    Oil cooler sandwich plate arrived.
    Such a nice piece. Setrab isn’t cheap but there’s a reason.
    D4E3F4A3-18E8-4E5E-BB49-2EDBA6E8672D.jpeg

    Also found this awesome article today somehow. Not sure how it didn’t come up in my earlier searches but damnnnnnnn. It’s a thing. Who knew?

    https://www.tomorrowstechnician.com/video-oil-pump-lost-its-prime/
     
    gotovato, via an iPhone, Aug 3, 2021
    • Like Like x 4
  20. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,811
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +2,340 / -13
    In all of my years and oil changes this is totally new to me
     
    Easter Bunny, via a mobile device, Aug 3, 2021
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)