Blow Off Valve - No Tune?

Discussion in 'Mazdaspeed 3 General Discussion' started by BrinkOfInfamy, Apr 20, 2020.

Watchers:
3 users.
  1. BrinkOfInfamy

    BrinkOfInfamy Greenie N00B Member

    Joined:
    Apr 20, 2020
    Posts:
    9
    Trophy Points:
    3
    Location:
    Saskatchewan, Canada
    Ratings:
    +2 / -0
    Hey all, just bought a 2013 MS3 about two weeks ago, just found this forum today!
    I've scoured the forums, but I can't seem to track down anything on this topic.
    I've heard varied responses to this:

    "These engines tend to grenade if you change anything without a tune."
    "It's fine to run a BOV without a tune, it'll just run rich between shifts and could ruin the cats over time."
    "It'll work, you'll just pop sometimes."

    I was wondering what you guys know on this? If it's safe to run a blow off valve without tuning for it? I just want to hear the noises, but a $1000 AP is way too much for me right now.
     
  2. BrinkOfInfamy

    BrinkOfInfamy Greenie N00B Member

    Joined:
    Apr 20, 2020
    Posts:
    9
    Trophy Points:
    3
    Location:
    Saskatchewan, Canada
    Ratings:
    +2 / -0
    Unrelated, but here's my new baby. Just wanted to share <3
     

    Attached Files:

  3. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    1,024
    Trophy Points:
    113
    Location:
    Iowa
    Ratings:
    +1,540 / -0
  4. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    1,446
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,117 / -3
    Adding onto JT another way to get some choo-choo noises is an intake, opens up the turbo and I noticed evens tatted hearing the stock bpv better. Now keep in mind with you gen2 speed without upgrading the hpfp just doing the intake can be a bad time, I ran my for a bit without internals but knowing what I do now I wouldn't have.
     
    Awafrican, via a mobile device, Apr 22, 2020
    #4
    • Like Like x 2
  5. BrinkOfInfamy

    BrinkOfInfamy Greenie N00B Member

    Joined:
    Apr 20, 2020
    Posts:
    9
    Trophy Points:
    3
    Location:
    Saskatchewan, Canada
    Ratings:
    +2 / -0
    • Like Like x 1
  6. BrinkOfInfamy

    BrinkOfInfamy Greenie N00B Member

    Joined:
    Apr 20, 2020
    Posts:
    9
    Trophy Points:
    3
    Location:
    Saskatchewan, Canada
    Ratings:
    +2 / -0

    Unfortunately, I can't afford the $400+ canadian dollars for the HPFP, and I wouldn't want to run the intake without properly tuning it, so that's another $1000 for an AP... I don't think I'll be doing any power mods for a while here.
     
  7. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    1,024
    Trophy Points:
    113
    Location:
    Iowa
    Ratings:
    +1,540 / -0
    JohnnyTightlips, via a mobile device, Apr 24, 2020
    #7
  8. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    1,446
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,117 / -3
    I feel your pain I'm in Canada as well, definitely one of the reasons my modding is slow compared to the time I've had the car...
    On the bright side gives you plenty of time to research and decide what parts you want when you do have the money
     
    Awafrican, via a mobile device, Apr 24, 2020
    #8
  9. BrinkOfInfamy

    BrinkOfInfamy Greenie N00B Member

    Joined:
    Apr 20, 2020
    Posts:
    9
    Trophy Points:
    3
    Location:
    Saskatchewan, Canada
    Ratings:
    +2 / -0

    Question!! Did you end up with a CEL with yours? Mine threw up the P0101 for the MAF sensor. I figure that's normal considering its not getting the right amount of air, but thought I'd ask!
     
    BrinkOfInfamy, via a mobile device, May 4, 2020
    #9
  10. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    1,024
    Trophy Points:
    113
    Location:
    Iowa
    Ratings:
    +1,540 / -0
    I did not get any codes from installing it. Are all your lines nice and tight?
     
    JohnnyTightlips, via a mobile device, May 4, 2020
    #10
  11. BrinkOfInfamy

    BrinkOfInfamy Greenie N00B Member

    Joined:
    Apr 20, 2020
    Posts:
    9
    Trophy Points:
    3
    Location:
    Saskatchewan, Canada
    Ratings:
    +2 / -0
    I'll have to double check tomorrow. I drove around the city without throwing a code, but once I left my friend's place it came on. I'm report back!
     
    BrinkOfInfamy, via a mobile device, May 5, 2020
    #11
  12. BrinkOfInfamy

    BrinkOfInfamy Greenie N00B Member

    Joined:
    Apr 20, 2020
    Posts:
    9
    Trophy Points:
    3
    Location:
    Saskatchewan, Canada
    Ratings:
    +2 / -0
    Well, sad day. I made sure all the lines were tight, cleared the code, and back it came. Now whenever I start the car, it smells like gas. Guess it's back to full recirc for this boy. Bit of a downer, but that's fine!
     
    BrinkOfInfamy, via a mobile device, May 5, 2020
    #12
  13. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    1,024
    Trophy Points:
    113
    Location:
    Iowa
    Ratings:
    +1,540 / -0
    You can adjust that gfb to recirc pretty much all of it.
     
    JohnnyTightlips, via a mobile device, May 5, 2020
    #13
  14. BrinkOfInfamy

    BrinkOfInfamy Greenie N00B Member

    Joined:
    Apr 20, 2020
    Posts:
    9
    Trophy Points:
    3
    Location:
    Saskatchewan, Canada
    Ratings:
    +2 / -0
    I don't see any way to a-- oh yeah it came with a block off thing. I'll try that out!
     
    BrinkOfInfamy, via a mobile device, May 5, 2020
    #14
  15. BrinkOfInfamy

    BrinkOfInfamy Greenie N00B Member

    Joined:
    Apr 20, 2020
    Posts:
    9
    Trophy Points:
    3
    Location:
    Saskatchewan, Canada
    Ratings:
    +2 / -0
    Entirely forgot that I posted this. I'm back for an update!

    After switching back to my factory recirc valve for a bit, I decided to go to my local Canadian Tire and get some gasket sheet stuff. I cut a new gasket, went outside, and tossed the 50/50 back on. It's been about two months running it at 50/50, and I've had no codes come up and no more issues at all. It's all good now! Thanks for recommending this one to me, guys!
     
    • Like Like x 1
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)