[SOLVED] Cylinder 3 Misfire

Discussion in 'Mazdaspeed 3 Troubleshooting' started by Mackinnon, Apr 7, 2021.

Watchers:
6 users.
  1. Mackinnon

    Mackinnon Greenie N00B Member

    Joined:
    Mar 30, 2021
    Posts:
    8
    Trophy Points:
    3
    Location:
    Canada
    Ratings:
    +3 / -0
    My car is misfing on cylinder 3 I put new plugs and coil packs In it did the compression test everything all cylinders were the same compression, some times it bucks and misfires then somedays it don't I been reading everyone's comments and trying to diagnose it myself but I can't seem to find the issue, the only thing I didn't check was my fuel injectors, i got gas on Friday parked my car and started it Saturday and its been acting up since if anyone of yous can help me I greatly appreciate it
     
    Mackinnon, via a Samsung mobile device, Apr 7, 2021
    #1
  2. neganox

    neganox Feline Führer Moderator Platinum Member

    Joined:
    Feb 9, 2016
    Posts:
    1,072
    Trophy Points:
    113
    Location:
    St Johns, FL
    Ratings:
    +2,033 / -5
    Crappy canadialand gas maybe?
     
  3. Mackinnon

    Mackinnon Greenie N00B Member

    Joined:
    Mar 30, 2021
    Posts:
    8
    Trophy Points:
    3
    Location:
    Canada
    Ratings:
    +3 / -0
    That's what I think it is just thought I'd ask on for more input thanks
     
    Mackinnon, via a Samsung mobile device, Apr 7, 2021
    #3
  4. Duey1083

    Duey1083 Gold Member

    Joined:
    Jun 4, 2020
    Posts:
    196
    Trophy Points:
    28
    Location:
    Canada
    Ratings:
    +81 / -0
    I've never had a misfire and I'm from Canada as well.

    How many km on your car? Do you know if the injectors have ever been cleaned or serviced? What mods do you currently have installed?

    Are you getting any CELs?

    EDIT: what spark plugs are you running and what are they gapped at?
     
    Duey1083, via a Samsung mobile device, Apr 7, 2021
    #4
  5. The_big_dill

    The_big_dill Greenie Member

    Joined:
    Jun 11, 2020
    Posts:
    182
    Trophy Points:
    28
    Location:
    Aurora, ON. Canada
    Ratings:
    +78 / -4
    What are your modifications, what are your compression numbers?
     
  6. Mackinnon

    Mackinnon Greenie N00B Member

    Joined:
    Mar 30, 2021
    Posts:
    8
    Trophy Points:
    3
    Location:
    Canada
    Ratings:
    +3 / -0
    It has a cobb access port cobb intake a catless downpipe and hpfp internals
    My compression is 160 on all cylinders

    My car has 211,638 on it and I don't the injectors were cleaned I just bought the car 2 weeks ago and the mods are it has hpfp internals, cobb access port, catless downpipe, cobb intake and the plugs are NGK Iridium IX LTR7IX-11 and I never gapped them I just put them in he said they were pre gapped and for cels I'm not to sure what you mean sorry
     
    Last edited: Apr 7, 2021
    Mackinnon, via a Samsung mobile device, Apr 7, 2021
    #6
  7. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,812
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +2,340 / -13
    You are going to want to check the gap on the sparkplugs
     
    Easter Bunny, via a mobile device, Apr 7, 2021
    #7
  8. Duey1083

    Duey1083 Gold Member

    Joined:
    Jun 4, 2020
    Posts:
    196
    Trophy Points:
    28
    Location:
    Canada
    Ratings:
    +81 / -0
    @Mackinnon, this is 100% correct. You are running a step colder plug and when I installed mine, I had to gap them to 0.026".

    CELs = check engine light

    In other words, is your car throwing any codes?
     
    Duey1083, via a Samsung mobile device, Apr 7, 2021
    #8
  9. Mackinnon

    Mackinnon Greenie N00B Member

    Joined:
    Mar 30, 2021
    Posts:
    8
    Trophy Points:
    3
    Location:
    Canada
    Ratings:
    +3 / -0
    The codes I get are its saying it's misfiring on cylinder 3 then ill clear it then it will say it's misfiring on all cylinders so P0300 and P0303
     
    Mackinnon, via a Samsung mobile device, Apr 7, 2021
    #9
  10. Awafrican

    Awafrican Moderator Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    2,472
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,871 / -7
    @Mackinnon you used OEM coil packs right? If you didn't you're going to have a bad time.
     
    Awafrican, via a mobile device, Apr 7, 2021
    #10
  11. Mackinnon

    Mackinnon Greenie N00B Member

    Joined:
    Mar 30, 2021
    Posts:
    8
    Trophy Points:
    3
    Location:
    Canada
    Ratings:
    +3 / -0
    Yes I did use oem ones
     
    Mackinnon, via a Samsung mobile device, Apr 7, 2021
    #11
  12. Duey1083

    Duey1083 Gold Member

    Joined:
    Jun 4, 2020
    Posts:
    196
    Trophy Points:
    28
    Location:
    Canada
    Ratings:
    +81 / -0
    Buy a feeler gauge and check your spark plug gap...they can cause misfires if they aren't gapped properly.

    The plugs you bought will have too large a gap from factory. Also check to ensure the ceramic part of the plug is not cracked or damaged.
     
    Duey1083, via a Samsung mobile device, Apr 7, 2021
    #12
    • Like Like x 1
  13. Mackinnon

    Mackinnon Greenie N00B Member

    Joined:
    Mar 30, 2021
    Posts:
    8
    Trophy Points:
    3
    Location:
    Canada
    Ratings:
    +3 / -0
    Hey man it was the spark plug gap I appreciate everyone that helped me thanks so much
     
    Mackinnon, via a Samsung mobile device, Apr 11, 2021
    #13
    • Like Like x 3
  14. Awafrican

    Awafrican Moderator Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    2,472
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,871 / -7
    Pesky spark plug gap glad it's fixed
     
    Awafrican, via a mobile device, Apr 11, 2021
    #14
  15. Mackinnon

    Mackinnon Greenie N00B Member

    Joined:
    Mar 30, 2021
    Posts:
    8
    Trophy Points:
    3
    Location:
    Canada
    Ratings:
    +3 / -0
    Yeah I should of checked them first, thanks again I appreciate the help
     
    Mackinnon, via a Samsung mobile device, Apr 11, 2021
    #15
  16. Duey1083

    Duey1083 Gold Member

    Joined:
    Jun 4, 2020
    Posts:
    196
    Trophy Points:
    28
    Location:
    Canada
    Ratings:
    +81 / -0
    No problem...glad you got your issue resolved!
     
    Duey1083, via a Samsung mobile device, Apr 11, 2021
    #16
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)