Gregg's street/track genpu

Discussion in 'Mazdaspeed 3 Build Diaries' started by Mr.Gregg, Sep 3, 2020.

Watchers:
7 users.
  1. gotovato

    gotovato Silver Member

    Joined:
    May 29, 2018
    Posts:
    643
    Trophy Points:
    93
    Location:
    Mississauga, Ontario
    Ratings:
    +811 / -0
    That makes sense to me for sure, fair enough. You’ll be happy with those tires both on the street and definitely on the track.
     
    gotovato, via an iPhone, Apr 19, 2021
    #61
  2. Kraze

    Kraze Silver Member

    Joined:
    Jan 18, 2021
    Posts:
    62
    Trophy Points:
    18
    Location:
    North Idaho
    Ratings:
    +53 / -0
    I'm having this same issue on my Gen 1. CS coilovers, Mevotech end links. Let me know what you end up doing to solve it!
     
  3. JohnnyTightlips

    JohnnyTightlips Motorhead Silver Member

    Joined:
    May 12, 2016
    Posts:
    1,411
    Trophy Points:
    113
    Location:
    Iowa
    Ratings:
    +2,132 / -0
    I am having the same issue on my juan. I ended up doing some clearance with a punch and hammer, then spraying truck bed liner over it. I am not sure if it is still rubbing or not as I have not looked at it. I have tried multiple endlinks and they all seem to do it.
     
    • Like Like x 1
  4. Mr.Gregg

    Mr.Gregg Greenie Member

    Joined:
    Jul 2, 2020
    Posts:
    59
    Trophy Points:
    8
    Location:
    Cleveland
    Ratings:
    +19 / -0
    Yep I'm reaaaaally hoping I don't have to take a hammer to it but there's so little room there that might be the only option. Do you know which endlinks didn't work out?
     
    Mr.Gregg, via a mobile device, Apr 23, 2021
    #64
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)