JohnnyTightlips Build "Maximum Carnage"

Discussion in 'Mazdaspeed 3 Build Diaries' started by JohnnyTightlips, Oct 9, 2018.

Watchers:
27 users.
  1. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    677
    Trophy Points:
    93
    Location:
    Iowa
    Ratings:
    +977 / -0
    Update:

    My battery had a small crack in it so I switched to the Van for a day. Took the battery to Walmart over my lunch hour and they said they could not take it back because of the crack and bio hazard or some shit. I was confused and was like...so what do I do with it? They had no answers and told me to call the manufacturer. I knew this would not help but I did as they asked. I called and the tech told me that Walmart should take it back and that he could not help me. SO, I called walmart and talked to the manager. After a few more phone calls they agreed to swap me for a new battery but they did not want the old one back. I was like OK , idgaf , I can take it to the junk yard if I need to , or add it to my suburban as a second battery. It still works fine just has a tiny leak. So I went back there and got it after 30 more minutes of people being confused and staring at me. OH FUN TIMES.

    [​IMG]

    So in my last post LTFT was hitting 12, well it kept going was was not hitting +17. When I originally installed the intake I was not to keen on how it say and it was touching the tray pretty tight. I think the PTE turbo might sit closer tot he drivers side. Well I did some check and make some cuts and not it fits MUCH better and it will still rub but only slightly and I have a rubber piece there to help. Once I got that all done and clamped on nicer the LTFT's returned to normal. It must have been sucking air in from the turbo clamp. I did a boost leak test and did not find anything crazy. One of the welds on an intercooler pipe has a needle small leak I found on accident and at some point I will jbwled it. But it is so small I don't see if being an issue right now.

    [​IMG]

    Once I got that all going I decided to finish installing the wotbox. I might make thread on this. It was not too hard but took some time and setup also takes time. I was able to use the USB cable that came with the wotbox, not sure if it was my mad IT skillz or just luck. WHen I was doing harness and engine out stuff I had make some nice connectors to keep this all pretty clean and removable. I need to make a spare jumper cable so I can jump the signal if the wotbox dies "go back to OEM" otherwise it is solid.
    [​IMG]

    @SharksInSpace would not stop harassing me about my side markers and how white they are. I decided to spray them with a can of VHT Nite-Shades and some Clear. I will make a how-to for this. The hardest part is getting the nite-shade a coat and darkness you want. I wanted it to just be tinted and not super dark. It turned out pretty nice.
    [​IMG]
    [​IMG]

    We had my brother-in-laws dog for the weekend. He is cute A/F but super annoying and never chills out.
    [​IMG]
     
    • Like Like x 5
  2. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    677
    Trophy Points:
    93
    Location:
    Iowa
    Ratings:
    +977 / -0
    Update:

    Thought I was making some progress on mafcal and tuning but for some reason I just can't hit load targets. @Enki seems to be having the same issue. Another member on the Versatune forum says their mafcal has also been lean no matter the changes. I did notice I have added a lot of fuel to my mafcal "more then I think I should" and have been running lean as well. SO now I am like wtf, I can't hit load and I can't trust my mafcal. steve@versatune so far is MIA and has not said anything on here or the VT forum. I am at a crossroads as I would love to get my 93 tune dialed in and move on. I did not have this issue last year but VT has been updated a few time since then. I am thinking of going back to the version I first used and start from scratch but ughhh what a pain in the ass.

    https://www.versatune.net/forum/viewtopic.php?f=13&t=3906
    WOT CSV - 3rd Gear

    I know I need to clean up the mafcal and I also have no idea why it lets loose at 7k. I have triple checked my tables. I thought it might be creep once I get that high in the RPM but it seems odd that it just jumps right at a tuning point where most stock cars will never be. Revving to 7500 is a good time but I did hit 110 idc at the very top.

    vdyno
    [​IMG]
     
    Last edited: Sep 11, 2019
    • Like Like x 3
  3. Easter Bunny

    Easter Bunny Professional Engineer Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    820
    Trophy Points:
    93
    Location:
    Earth
    Ratings:
    +1,256 / -5
    Looks slow
     
    Easter Bunny, via a mobile device, Sep 5, 2019
    • Like Like x 1
  4. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    677
    Trophy Points:
    93
    Location:
    Iowa
    Ratings:
    +977 / -0
    Update:

    Not much to report. Hit my 1000+ miles "more like 1200" and have changed the car over to the good shit. Going to start doing some more tuning on it. @mituc offered to help me get my VT problems sorted so that is awesome. If anyone else uses this make sure you shake the shit out of the bottles before pouring in. The additives like to settle as it sits on the shelf.

    I have not really had any issues with leaks of oil being eaten. I thought I had a leak on my timing cover but it turned out to be my VC vent. For now I am going to use the OEM one until I am in the big boost then I will work out another plan of attack. I do still have a small leak at the turbo drain but I have not wanted to try and tackle that. Maybe a winter project or maybe a never project since it is such a small leak.

    [​IMG]
     
    • Like Like x 6
  5. StreetSpeed6

    StreetSpeed6 Welder Silver Member

    Joined:
    Mar 1, 2018
    Posts:
    330
    Trophy Points:
    43
    Location:
    Bedford, Indiana
    Ratings:
    +183 / -0
    I’m almost at 500 miles now and am still deciding whether or not to go with something I can buy local or get the Tribodyn.
     
    StreetSpeed6, via an iPhone, Sep 11, 2019
  6. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    677
    Trophy Points:
    93
    Location:
    Iowa
    Ratings:
    +977 / -0
    I didn't think the price was too bad but now summit no longer carries the one I need so we will see how long I run it for. I might be buying it from oddball but will have to see what they can do. I would need to check to see what is on the recommended list of anything that might be local if I don't go that route.
     
    • Like Like x 1
  7. StreetSpeed6

    StreetSpeed6 Welder Silver Member

    Joined:
    Mar 1, 2018
    Posts:
    330
    Trophy Points:
    43
    Location:
    Bedford, Indiana
    Ratings:
    +183 / -0
    Pen Platinum is one I think but also haven’t decided whether to run 5w 30 or 5w 40.
     
    StreetSpeed6, via an iPhone, Sep 12, 2019
  8. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    677
    Trophy Points:
    93
    Location:
    Iowa
    Ratings:
    +977 / -0
    Everyone seems to run 40 so that is what I would go with.
     
    • Like Like x 1
  9. Mauro_Penguin

    Mauro_Penguin Punk in Drublic Motorhead Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    917
    Trophy Points:
    93
    Location:
    Jacksonville, FL
    Ratings:
    +1,008 / -2
    These engines run stupid hot.

    It only gets worse with any turbo bigger than the k04.

    5w40 is a great viscosity for the heat our engines put out. 5w30 might be good if you have an oil cooler and a bunch of other cooling mods.
     
    Mauro_Penguin, via a mobile device, Sep 12, 2019
    • Like Like x 4
  10. StreetSpeed6

    StreetSpeed6 Welder Silver Member

    Joined:
    Mar 1, 2018
    Posts:
    330
    Trophy Points:
    43
    Location:
    Bedford, Indiana
    Ratings:
    +183 / -0
    I appreciate the advice guys. I had a thermostat that was basically stuck open before the build so I always kept my temps around 175 until I really ran it hard lol Was kind of nice in a way actually haha
     
    StreetSpeed6, via an iPhone, Sep 12, 2019
  11. _Mazdarati

    _Mazdarati Silver Member

    Joined:
    Mar 13, 2017
    Posts:
    303
    Trophy Points:
    63
    Location:
    Dearborn, MI
    Ratings:
    +338 / -2
    My 7qts of 0w40 Penn ultra plat from summit, with a wix filter comes out to like $110 or so shipped if I remember correctly.
     
    _Mazdarati, via a mobile device, Sep 12, 2019
  12. Eroler1

    Eroler1 Greenie Member

    Joined:
    Jan 27, 2018
    Posts:
    137
    Trophy Points:
    28
    Location:
    Hawaii
    Ratings:
    +42 / -5
    sorry if thread jacking but how bout the full synthetic valvoline vr1? any opinion bout that oil
    I used it once till my oil pump went RIP
     
  13. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    677
    Trophy Points:
    93
    Location:
    Iowa
    Ratings:
    +977 / -0
    @Eroler1 I don't know anything about that oil, sorry man.

    UPDATE:

    Did a compression test. About 1300 miles on her now. 150 across the board with the harbor freight kit. Really happy to see them all be the same and the plugs looked great too.
    [​IMG]

    Cyl 1
    [​IMG]

    Cyl 2
    [​IMG]

    Cyl 3
    [​IMG]

    Cyl 4
    [​IMG]
     
    • Like Like x 5
  14. Enki

    Enki Motorhead Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    942
    Trophy Points:
    93
    Location:
    Tucson
    Ratings:
    +1,562 / -1
    I had one of those hatred fraught comp testers...Turns out it was leaking for anything past 150 and wouldn't read properly as a result. Get a good kit and restest.
     
    • Like Like x 2
  15. JohnnyTightlips

    JohnnyTightlips Platinum Member

    Joined:
    May 12, 2016
    Posts:
    677
    Trophy Points:
    93
    Location:
    Iowa
    Ratings:
    +977 / -0
    Yeah...if I can find one I would for sure do it but right now I am happy with these results. I did read a review where someone did maths and said it would read lower due to the design. So @Enki if you want to do the wizard voodoo math just let me know lol.

    [​IMG]
     
    • Like Like x 1
  16. StreetSpeed6

    StreetSpeed6 Welder Silver Member

    Joined:
    Mar 1, 2018
    Posts:
    330
    Trophy Points:
    43
    Location:
    Bedford, Indiana
    Ratings:
    +183 / -0
    I’m pretty sure I have the same set as you Johnny. I would have freaked out if I wouldn’t have known about it reading lower than normal lol My motor read mid 150’s before the rebuild tho so I assume it will be much higher this time around.
     
    StreetSpeed6, via an iPhone, Sep 18, 2019
  17. Enki

    Enki Motorhead Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    942
    Trophy Points:
    93
    Location:
    Tucson
    Ratings:
    +1,562 / -1
    Don't hold your breath.

    This one read a lot higher and more accurately with fewer cranks than the HF one:

     
  18. SharksInSpace

    SharksInSpace Planets and shit. Silver Member

    Joined:
    Apr 5, 2016
    Posts:
    1,273
    Trophy Points:
    113
    Location:
    Middle Coast
    Ratings:
    +1,411 / -11
    Rent one from vatozone, iirc OTC is the brand they lent me.
     
    • Like Like x 2
  19. Db09ms3

    Db09ms3 Silver Member

    Joined:
    Apr 20, 2017
    Posts:
    258
    Trophy Points:
    43
    Location:
    AZ
    Ratings:
    +224 / -1
    • Like Like x 1
  20. Enki

    Enki Motorhead Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    942
    Trophy Points:
    93
    Location:
    Tucson
    Ratings:
    +1,562 / -1
    The harbor freight one I have leaks at the crimps. Hard to fix that. Fortunately the OTP one I have is spot on and no hissing.
     
    • Like Like x 1
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 2)