Killing KR

Discussion in 'Mazdaspeed 3 Troubleshooting' started by krimsonviper, Jun 28, 2020.

Watchers:
3 users.
  1. krimsonviper

    krimsonviper Forward! Greenie Member

    Joined:
    Jul 1, 2019
    Posts:
    33
    Trophy Points:
    8
    Location:
    Suisun City
    Ratings:
    +19 / -1
    2010 MS3 no power mods
    Stock HPFP and COBB OTS stage 0 map
    115k miles
    Valve cleaning, injector cleaning, and Overspeed seals done at 100k and timing chain done at 95k. Only have 91 octane available.

    I fixed a few boost leaks that were causing me to have a little over 6 KR and its down to just under 3 KR at WOT. Trying to move it to close to 0 if not zero.

    Please. Read. The. Files.

    Only 1 person told me I may have some leaks because my STFT/LTFT were both maxing out -/+ and the AFR was in the 9's and everyone else told me my KR was that high simply because it's COBB stage 0 map and the one guy was right. Hoping someone else or the same guy can see my readings and tell me where else to look for problems. I didn't find any other leaks, but I am willing to bring it to a shop for a smoke test if recommended and makes sense at this point. My STFT/LTFT both are close to zero when cruising compared to before but the AFR dropped to 8 at one point in an unrecorded pull post fix.

    Third gear:

    Fourth gear:
     
  2. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    1,382
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,068 / -3
    Here is a good post about ltft original thread
    https://mazdaspeeds.org/index.php?threads/accessport-v3-parameter-monitoring.9757/#post-75719

    Also yes Cobb ots maps are known to cause knock plenty of threads on that, uninstall it ie Flash back to stock map and see how it is. If that resolves your issue then I'd pay the money and get an actual OTS map from someone like freektune who will do 1-2 revisions for your car.
    Also how old are the plugs/ what's their condition, you need to be on-top of plug changes on the speed.
     
    Awafrican, via a mobile device, Jun 28, 2020
    #2
    • Like Like x 2
  3. mangosmoothie

    mangosmoothie Platinum Member

    Joined:
    Sep 14, 2016
    Posts:
    370
    Trophy Points:
    63
    Location:
    Cincinnati
    Ratings:
    +358 / -3
    are you putting the pedal to the floor? The throttle position % doesn't look right at all. I believe that is the throttle plate position you are logging and it should stay at like 76 at wide open.

    But yeah I agree with awafrican. Check the plugs and gap (can gap them to .024), replace them if they're over 15k miles old (yes, I know they're supposed to last longer than that). If you have access to E85, put in 1-2 gallons of E85 and top off with 91/93. Drive 20 miles or so then grab another log. If the KR goes away or looks significantly better, there's something going on and it's real kr. If it stays the same, you're getting false kr. Could be injector seals, something rattling, etc. But I still don't think that throttle position looks right at all so we should figure that out first.
     
    • Like Like x 2
  4. krimsonviper

    krimsonviper Forward! Greenie Member

    Joined:
    Jul 1, 2019
    Posts:
    33
    Trophy Points:
    8
    Location:
    Suisun City
    Ratings:
    +19 / -1
    How do I monitor KR without the AP?

    I understand the OTS maps are trash and as soon as I start modding I will get one but I’m trying to see if there’s anything in particular that could be causing underlying issues like how I mentioned someone reading my logs and saying I have a leak which turned out to be true and how the poster below you mentioned TB position.

    I saw that my TB isn’t opening completely and I have the pedal to the floor and have been thinking about replacing, but wasn’t sure if the computer is stopping the TB from opening further due to the knock or if that’s even a thing.

    Regarding the corn, would that be safe? If so I will stop by someplace that sells it. I’m in a fairly populous area and I’m sure there’s a station or two that has it.
     
    krimsonviper, via an iPhone, Jun 29, 2020
    #4
  5. krimsonviper

    krimsonviper Forward! Greenie Member

    Joined:
    Jul 1, 2019
    Posts:
    33
    Trophy Points:
    8
    Location:
    Suisun City
    Ratings:
    +19 / -1
    Oh and regarding plugs, I didn’t know they needed to be changed that frequently. I just put them in at 100k and gapped to .026. I am ordering some parts from Edge now so I’ll throw in a set even though they’re a bit expensive on their site. I’m just ordering a $5 gasket and they want $15 in shipping for it. Might as well use the $15 shipping fee.
     
    krimsonviper, via an iPhone, Jun 29, 2020
    #5
  6. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    1,382
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,068 / -3
    Awafrican, via a mobile device, Jun 29, 2020
    #6
    • Like Like x 1
  7. krimsonviper

    krimsonviper Forward! Greenie Member

    Joined:
    Jul 1, 2019
    Posts:
    33
    Trophy Points:
    8
    Location:
    Suisun City
    Ratings:
    +19 / -1
    I didn’t know you didn’t have to flash the OTS map on it. Everyone I talked to said I had to flash the stage 0 and before installing I didn’t see an option for stock map. Gonna go ahead and check out how to do that after I read that thread you shared. Thank you!
     
    krimsonviper, via an iPhone, Jun 29, 2020
    #7
    • Like Like x 1
  8. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    1,382
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,068 / -3
    So there should be an "install" and "monitoring" once it's uninstalled just don't reinstall it that'll keep stock map and then go to monitoring and you should be able to set your screen and take datalogs from there. Thread I posted had a specific post from Cobb about it, look for that post
     
    Awafrican, via a mobile device, Jun 29, 2020
    #8
    • Like Like x 2
  9. krimsonviper

    krimsonviper Forward! Greenie Member

    Joined:
    Jul 1, 2019
    Posts:
    33
    Trophy Points:
    8
    Location:
    Suisun City
    Ratings:
    +19 / -1
    I’ll go and do what you mention. The post you point to is no longer relevant because COBB changed their site and no longer has the mentioned map the COBB employee said one can download.
     
    krimsonviper, via an iPhone, Jun 29, 2020
    #9
  10. Awafrican

    Awafrican Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    1,382
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,068 / -3
    This is the key point I was getting at "You can use the data logging and CEL reading functions of the Accessport without installing the Accessport, but some of the data logging parameters may show incorrect values. As such, we do not generally recommend that you do this."

    Stage 0 is supposed to be stock ROM data that enables install of access port. " Stage 0 is the stock ROM data but that allows you to marry the Accessport " -cobb (at least on the gtr https://www.gtrlife.com/forums/topic/285410-do-you-backup-your-stock-map-for-cobb/ )

    Which I know is what you're running so that's odd
     
    Awafrican, via a mobile device, Jun 29, 2020
    #10
    • Like Like x 1
  11. mangosmoothie

    mangosmoothie Platinum Member

    Joined:
    Sep 14, 2016
    Posts:
    370
    Trophy Points:
    63
    Location:
    Cincinnati
    Ratings:
    +358 / -3
    the corn is safe as long as you keep it under 2 gallons in a full tank. The ethanol percent isn't very high, but it's a noticeable enough octane increase to troubleshoot.

    You should be able to do key on engine off and hit the pedal. add accelerator pedal position to the log list. floor it (engine off) and see what happens. I think accelerator pedal pos should be 97-99 and throttle should be 76
     
    • Like Like x 1
  12. krimsonviper

    krimsonviper Forward! Greenie Member

    Joined:
    Jul 1, 2019
    Posts:
    33
    Trophy Points:
    8
    Location:
    Suisun City
    Ratings:
    +19 / -1
    So I don’t have a monitor option for my AP.

    **EDIT**
    Just got off the phone with COBB and there’s no way to monitor without it being married. The stage 0 map is the only option for me in order to monitor.

    As for what Mangos talked about I don’t think that’s possible with the engine off. The accelerator pedal position changes but the throttle position doesn’t change
     

    Attached Files:

    Last edited: Jul 1, 2020 at 5:14 PM
  13. krimsonviper

    krimsonviper Forward! Greenie Member

    Joined:
    Jul 1, 2019
    Posts:
    33
    Trophy Points:
    8
    Location:
    Suisun City
    Ratings:
    +19 / -1
    I should mention accelerator goes to 103-105 and the throttle is 8/8
     
  14. mangosmoothie

    mangosmoothie Platinum Member

    Joined:
    Sep 14, 2016
    Posts:
    370
    Trophy Points:
    63
    Location:
    Cincinnati
    Ratings:
    +358 / -3
    Darn. I don't have a speed anymore so idk how to test. Something seems whacky if the accelerator pedal going past 100
     
    mangosmoothie, via a mobile device, Jul 1, 2020 at 5:36 PM
    #14
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)