KR between 3500-4000rpm

Discussion in 'Mazdaspeed 6 Troubleshooting' started by RyanMunsell, Oct 17, 2020 at 6:01 PM.

Watchers:
3 users.
  1. RyanMunsell

    RyanMunsell Greenie N00B Member

    Joined:
    Jul 13, 2020
    Posts:
    6
    Trophy Points:
    1
    Location:
    Bothell, Washington
    Ratings:
    +0 / -0
    Been trying to figure this out for a couple months now so figured I'd see if anyone has had the same problem. Tuner(Alan at Edge) is pretty sure it's false knock but I can't seem to find the source, and Ive gone over the whole bay without pulling the intake manifold. It typically peaks at 2.1 and then tapers off quickly. Seems like if it was real knock it wouldnt go away. Did a compression test and looked at the plugs yesterday. Compression test is good(all ranged from 175-185). Plugs all looked the same, but looks like they got pretty hot and have a bit of carbon buildup(pic attached). Alan recomended replacing the plugs and gapping them at.026 so i did that. Havent taken a log yet, but driving it around I see the the knock is still there by watching the AP. Attached one of the 4th WOTlogs below. TIA for any help

    Here is my mod list:
    .Corksport CST4 turbo
    .Cobb electronic boost control solenoid
    .Corksport SRI and TIP
    .Corksport fuel injector seals
    .Corksport BPV
    .Corksport throttle body
    .CX Racing FMIC
    .Cobb accesport
    .Damond motor mounts
    .Damond dual oil catch can
    .Damond EGR delete
    .JBR balance shaft delete/oil pan baffle
    .Supertech Pistons 88mm bore
    .K1 Rods
    .Mahle clevite rod bearings
    .NGK 6510 iridium spark plugs .024 gap
    .Corksport short shift plate
    .Corksport HPFP internals
    .3 inch turboback exhaust, no cat, no resonator, Magnaflow mufflers
    .Sure short shift plate
    .H&R lowering springs
    .KYB front struts
     

    Attached Files:

  2. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    5,224
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +6,324 / -5
    Probably false knock. Very common. Solid mounts can do that.
     
    Raider, via a mobile device, Oct 18, 2020 at 7:06 AM
    #2
    • Like Like x 1
  3. Awafrican

    Awafrican Moderator Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    1,688
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,327 / -3
    So you have access to Ethanol? Toss in a couple gallons, if it goes away definitely false knock and you're good to go. As too Estates causing it, probably just picking up more noise because of motor mounts perfectly normal.
     
    Awafrican, via a mobile device, Oct 18, 2020 at 9:55 AM
    #3
  4. RyanMunsell

    RyanMunsell Greenie N00B Member

    Joined:
    Jul 13, 2020
    Posts:
    6
    Trophy Points:
    1
    Location:
    Bothell, Washington
    Ratings:
    +0 / -0
    If it goes away with ethanol wouldn't that mean it's real knock? I'd have to drive a ways to get some ethanal. Would an octane booster like royal purple max work?
     
    RyanMunsell, via a mobile device, Oct 18, 2020 at 12:34 PM
    #4
  5. Awafrican

    Awafrican Moderator Silver Member

    Joined:
    Feb 11, 2016
    Posts:
    1,688
    Trophy Points:
    113
    Location:
    Canada
    Ratings:
    +1,327 / -3
    Means it's happen because of fuel, could have been a bad batch of fuel in the tank. Means it's not a mechanical thing or rod knock or piston slap.

    Would allow Alan to adjust some timing for your tune so it doesn't keep happening. I've seen it happen from just a bad batch of gas. What are you running on 91/93? Even upping the octane if around you would help, octane booster may help, for troubleshooting I'm not overly knowledgeable on that sector I know prolonged use of them is bad but don't know how truly effective they are either to say yup use it instead of ethanol.
     
    Awafrican, via a mobile device, Oct 18, 2020 at 12:58 PM
    #5
  6. RyanMunsell

    RyanMunsell Greenie N00B Member

    Joined:
    Jul 13, 2020
    Posts:
    6
    Trophy Points:
    1
    Location:
    Bothell, Washington
    Ratings:
    +0 / -0
    So put in the new plugs as recommended by Alan and the KR seems have gotten worse. Doesn't happen every pull, but when it does it goes into the high 3's-low 4's
     
    RyanMunsell, via a mobile device, Oct 18, 2020 at 5:50 PM
    #6
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)