Sickms3's BT Build

Discussion in 'Mazdaspeed 3 Build Diaries' started by sickms3, Feb 16, 2016.

Watchers:
11 users.
  1. Dub-S2K

    Dub-S2K Greenie Member

    Joined:
    Feb 16, 2016
    Posts:
    30
    Trophy Points:
    18
    Location:
    DFW
    Ratings:
    +29 / -1
    Nice to keep seeing the progress. Thing should be rolling soon. My order is partially shipped (looks like your new clutch should arrive Thursday by end of day) :)
     
    Dub-S2K, via an iPhone, Apr 12, 2016
    #21
    • Like Like x 1
  2. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    Picked up my valve cover and roll cage from the powder coater yesterday.
    [​IMG]
    [​IMG]

    Going to put the rear main seal on today and then start throwing on the rest of the parts to hopefully drop the engine in Saturday.

    Sent from my SAMSUNG-SM-N920A using Tapatalk
     
    sickms3, via a mobile device, Apr 13, 2016
    #22
    • Like Like x 2
  3. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    [​IMG]
    [​IMG]

    Sent from my SAMSUNG-SM-N920A using Tapatalk
     
    sickms3, via a mobile device, Apr 13, 2016
    #23
    • Like Like x 5
  4. TRBLSM

    TRBLSM Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    62
    Trophy Points:
    18
    Location:
    Canberra
    Ratings:
    +71 / -0
    Damn!! Thats too pretty to install


    Tapatorque steering
     
    TRBLSM, via a mobile device, Apr 14, 2016
    #24
    • Like Like x 2
  5. Maisonvi

    Maisonvi Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    1,278
    Trophy Points:
    113
    Location:
    South Haven, MI
    Ratings:
    +1,689 / -0
    that shit would never stay clean for me. I already have a hard time keeping my silver and black shit clean
     
    • Like Like x 1
  6. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    Incoming picture dump.

    Kozmic Primary EGR Delete
    [​IMG]

    CPE Safe Seal installed on an injector cleaned, inspected and tested by InjectorRX. Was never happy with CPE seals from what I read on the forums.
    [​IMG]

    Injectors installed and you can see the Perm PCV Plate. Due to my venting plan, I sold the Perm plate and went back to the OEM plate.
    [​IMG]

    Ultimately decided to go with the CS seals because they are designed better.
    [​IMG]

    Mo betta!!
    [​IMG]

    Southbend Stage 3 Endurance
    [​IMG]

    [​IMG]

    [​IMG]

    This stud needs to be removed to provide clearance for Precision turbo's with CPE manifolds. Not sure about other turbo/manifold combos.
    [​IMG]

    I believe this was a 1.25mm pitch coarse thread stud.
    [​IMG]

    PTE 5858 .82ar Goodness
    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    Wrong fittings for the oil return line. Sent a PM to David @ Kozmic and he took care of me. Dude is fantastic!!!
    [​IMG]

    45* fittings received
    [​IMG]

    Oil return done. The oil feed line is pre-made and is on top of the turbo.
    [​IMG]

    Installing the JMF IM requires the fuel rail sensor to be relocated using the included adapter. This is the proper alignment for the sensor.
    [​IMG]

    Got clearance?
    [​IMG]

    JMF actually installed now. I would advise to remember to connect the fuel injector harness and knock sensor BEFORE putting the intake manifold on. I didn't and would have really hated life had I not looked everything over for a good 30 minutes before calling that side of the engine DONE.
    [​IMG]

    Pulled the trans off my old engine. Cleaned it up a bit but not much.
    [​IMG]

    Old throw out bearing after 124,000 miles. It spun but the bearings felt a bit grainy and there was a lot of play in it.
    [​IMG]

    Old vs New
    [​IMG]

    As it sits as of 05/16/16. I need to torque the flywheel, add the pressure plate and mount the trans. Hoping to fire it up by the end of the weekend!!
    [​IMG]
    --- Double Post Merged, May 17, 2016 ---
    Had money in PayPal from selling the CPE seals and Perm plate, so I picked this up. My stock wheels is 7 years old and showing signs of wear. Can't wait to try this out.
    [​IMG]

    [​IMG]

    Sold my stock injectors and purchased this plate. Totally stole this plate idea from a MS3 I saw on FB last week. LOL!!!
    [​IMG]
     
    • Like Like x 6
  7. Redline

    Redline I done fucked up for the last time. BANNED Greenie Member

    Joined:
    Feb 12, 2016
    Posts:
    2,699
    Trophy Points:
    113
    Location:
    Bannedville
    Ratings:
    +1,153 / -71
    Sweet! Really looking to see the finished, final-tuned product on the road. And I'd like some shotgun rides too, if you don't mind :D

    So the question is, when can I meet up with you and pull trains before your engine is broken in and you're tuned up? I know my time is running short!! :p
     
  8. zjnspeed3

    zjnspeed3 Greenie Member

    Joined:
    May 7, 2016
    Posts:
    15
    Trophy Points:
    3
    Location:
    Davey, NE
    Ratings:
    +5 / -0
    In for tuning results and dyno/road pulls!
     
    zjnspeed3, via a mobile device, May 17, 2016
    #28
  9. Sho

    Sho Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    675
    Trophy Points:
    93
    Location:
    Akron, OH
    Ratings:
    +1,103 / -0
    Nice build, sir! Looking forward to seeing what it puts down
     
    Sho, via a mobile device, May 20, 2016
    #29
  10. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    Engine is in. Will wrap it up tomorrow. [​IMG]

    Sent from my SAMSUNG-SM-N920A using Tapatalk
     
    sickms3, via a mobile device, May 22, 2016
    #30
    • Like Like x 4
  11. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    I took off yesterday thinking I'd finish everything. Nope!!

    First, I ran into an issue with this hardline to the oil cooler. It was pushing up against the coupler on the turbo which prevented the intake from going in.
    [​IMG]

    Made a new line.
    [​IMG]

    Plenty of room now.
    [​IMG]

    Started on the wire tuck. I have everything in place and will need to re-wrap a few connections. Everything is under the manifold and HPFP now.
    [​IMG]

    Things left to do:

    1. Finish the engine harness
    2. Wiring for the gauges (Oil Pressure, AEM Failsafe, Aquamist Controller)
    3. Plumbing for the intake manifold
    4. Mount the radiator core support and connect hoses
    5. Replace driver's side transmission seal
    6. Install axles, connect brakes and suspension
    7. Fill fluids
    8. First start!!!
     
    Last edited: May 24, 2016
    • Like Like x 3
  12. Redline

    Redline I done fucked up for the last time. BANNED Greenie Member

    Joined:
    Feb 12, 2016
    Posts:
    2,699
    Trophy Points:
    113
    Location:
    Bannedville
    Ratings:
    +1,153 / -71
    Minor favor to ask, Jason: may I be there for the first start? Puuuleeease? I'm just down the road. SRS :D
     
    Last edited: May 24, 2016
  13. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    Anyone is welcome to come by. Lol

    I don't know when I'll be done, but the second I am, I'm starting it.
     
    • Like Like x 3
  14. Chemmedic

    Chemmedic Greenie Member

    Joined:
    Feb 14, 2016
    Posts:
    67
    Trophy Points:
    18
    Location:
    Kingston ON
    Ratings:
    +45 / -0
    Man sexiness!!!

    I just started mine on friday, second test drive was today. Going to road test tomorrow.
     
    • Like Like x 1
  15. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    What a headache this has been. An uphill battle is an understatement. But for the most part, it's done. I was hoping to start it today, but it started raining and I really didn't want to drive this around and have something happen requiring me to fix it in the rain.

    So, I'll try again tomorrow. I need to get a larger hose for the wastegate and wire up the gauges. Mainly the oil pressure gauge. I don't exactly need the failsafe while I'm breaking in the engine.

    TR8 with COBB brackets that were utter crap. The brackets for the power steering line weren't working at all. Ended up just using a ton of zip tips with triple redundancy. LOL
    [​IMG]

    As it sits now.
    [​IMG]

    Sent from my SAMSUNG-SM-N920A using Tapatalk
     
    sickms3, via a mobile device, Jun 12, 2016
    #35
    • Like Like x 3
  16. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    I moved some things around under the intake and got the battery terminal to reach. It's tight getting over the post on the battery but loosens up once it's on it.

    Ran into some pre-start issues.

    First, while priming the fuel pump by turning the key to the on position a few times, I noticed fuel dumping on the ground. I didn't have the fuel line on the fuel rail connected all the way. Easy fix.

    Second, I had to add almost a whole bottle of Motul brake fluid since the clutch went straight to the floor. I bled the slave cylinder and all was well.

    Now I was ready to start the engine. I performed a number of full throttle cranks to get the oil to move through the engine a bit. That's what you see at the beginning of the video. The engine started on the first real attempt to start it.



    After idling for a few minutes:


    Pistons are pretty damn loud. I have 2 coolant leaks and a tiny oil leak that I need to take care of.
     
    • Like Like x 1
  17. Redline

    Redline I done fucked up for the last time. BANNED Greenie Member

    Joined:
    Feb 12, 2016
    Posts:
    2,699
    Trophy Points:
    113
    Location:
    Bannedville
    Ratings:
    +1,153 / -71
    Kinda sounds like you may have an exhaust leak too? Or am I just imagining things. I notice that characteristic lawnmower sort-of sound, but it's hard to tell just by a vid. Cheers, BTW!!!

    Just out of curiosity, what PWC did you end up on? And what ring-end gaps are you running?
     
  18. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    Yeah, I'm pretty sure the downpipe isn't tight enough.

    As for PWC and end gap, I don't know. That was handled by the machine shop.
     
  19. Redline

    Redline I done fucked up for the last time. BANNED Greenie Member

    Joined:
    Feb 12, 2016
    Posts:
    2,699
    Trophy Points:
    113
    Location:
    Bannedville
    Ratings:
    +1,153 / -71
    Any way you can find out? I'm doing research for an in the future build. No build sheet supplied?

    I'm supposing they just asked you what your hp goals were and how much boost you were going to run?
     
  20. sickms3

    sickms3 Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    66
    Trophy Points:
    18
    Location:
    Grand Prairie, TX
    Ratings:
    +82 / -0
    You're digging way too much into things. Just let the machine shop do what they do. I couldn't even begin to tell you what they should be nor do I still have the sheet if it was even listed.
     
    • Like Like x 1
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)