Can't figure out! no idea

Discussion in 'Mazdaspeed 3 Troubleshooting' started by Speed777, May 26, 2021.

Watchers:
4 users.
  1. Speed777

    Speed777 Silver Member

    Joined:
    Feb 24, 2021
    Posts:
    46
    Trophy Points:
    8
    Location:
    P.R.
    Ratings:
    +7 / -2
    Ok guys. Im getting this warning on my cluster. I tried disconnecting the battery for a long time, still comes back. I scanned the car with the Cobb AP two times but the ap tells me no codes registered. I have no idea to what can this be. I could think its a bad abs sensor but which one because it doesn't let you know and that is if its the cause. I'm attaching a picture so you can see to what I'm talking about. Thanks in advance for the help!

    Check engine light.jpeg
     
  2. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,812
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +2,340 / -13
    Thats abs.
     
    Easter Bunny, via a mobile device, May 26, 2021
    #2
    • Like Like x 2
  3. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    5,913
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +6,939 / -8
    The ABS light is you have an issue with the ABS system. Might be dirty or disconnected.
     
    Raider, via an iPhone, May 26, 2021
    #3
    • Like Like x 1
  4. neganox

    neganox Feline Führer Moderator Platinum Member

    Joined:
    Feb 9, 2016
    Posts:
    1,072
    Trophy Points:
    113
    Location:
    St Johns, FL
    Ratings:
    +2,033 / -5
    You can take it to an alignment shop and they can scan for ABS codes or just reset/clear them for you.
     
    • Like Like x 1
  5. Speed777

    Speed777 Silver Member

    Joined:
    Feb 24, 2021
    Posts:
    46
    Trophy Points:
    8
    Location:
    P.R.
    Ratings:
    +7 / -2
    Thanks guys! When scanning the abs, does it let you know which abs sensor is faulty?
     
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)