GEN1 MAZDASPEED 3 NO BOOST

Discussion in 'Mazdaspeed 3 Troubleshooting' started by Anthony Amador, Aug 17, 2021.

Tags:
Watchers:
6 users.
  1. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,811
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +2,340 / -13
    You need your tune to reflect the different intake and turbo.
     
    Easter Bunny, via a mobile device, Aug 24, 2021
    #81
    • Like Like x 1
  2. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    I changed spark plugs, I also replaced the vacuum lines for my EBCS.

    nothing changed. I got the 2 codes

    P2009 - VTCS solenoid low current
    P0403 - EGR something? (I deleted the EGR)

    My fuel trims are still negative, I have PTO until 9/4. I’m gonna take it this time to go through every inch of my system, I hope I figure this out.
     
    Anthony Amador, via an iPhone, Aug 24, 2021
    #82
  3. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    I will plan on it!

    I’m just waiting I’ll payday, and I’m contacting FREEKTUNE.
     
    Anthony Amador, via an iPhone, Aug 24, 2021
    #83
  4. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    Update.

    I used a vacuum pump on my engine.

    I’m able to hold 20 vacuum on my wastegate, my brake booster, and on my purge valve I can’t really test too well.

    I found a fuel leak from my fuel return (low pressure) hose. I’m going to replace that.

    let me add this whenever I make boost my engine sounds normal, turbo spools, I hear my BPV functioning. When I do not build boost I get a very low grumble. Sounds like the wastegate just flying open and I hear the engine more clearly. I’m attaching a video of the noise.
     

    Attached Files:

    Anthony Amador, via an iPhone, Aug 24, 2021
    #84
  5. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    Car is still not fixed. HELP ME FIND A REPUTABLE SHOP OR PERSON THAT KNOWS ABOUT THESE CARS MIAMI AREA

    I do not know what to do from this point on now. I've checked all of the parts involved in boosting, but still stumped. Anyone live near Miami and think they can figure this out? I am more than willing to deliver the car, and pay for the repairs.

    The shops down here cannot figure it out, $1260 down the drain in labor and fees, still no answer to what's going on. Some tell me "Get a new ECU" (Quoted $964) Some say "Change timing" (Quoted $1276) . I do not know what to pay for or what to replace.

    The car has been parked for months, and it's honestly hurting me to see it like this. I want to take it to someone reputable, and knowledgeable on these platforms. If anyone knows someone near me, or a shop they trust, send them my way.

    Thanks for the help, but for now, i am done trying to diagnose this on my own, or with not so great shops.
     
  6. L337TurboZ

    L337TurboZ Master Technician Silver Member

    Joined:
    Jun 15, 2020
    Posts:
    420
    Trophy Points:
    63
    Location:
    Charleston, South Carolina USA
    Ratings:
    +394 / -4
    Dude post some logs from your access port.
     
    L337TurboZ, via a Motorola device, Sep 8, 2021
    #86
    • Like Like x 3
  7. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    I can’t. For some reason my AP is not recognized by my computer now. It thinks it’s a storage device. I can’t even get it to open in AP Manager.
    I posted a log a couple of replies back, nothing has changed since that log.


    I’ve contacted COBB and they’re trying to help me figure it out. Until then that’s the only Log I have
     
    Anthony Amador, via an iPhone, Sep 8, 2021
    #87
  8. Enki

    Enki Motorhead Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    1,523
    Trophy Points:
    113
    Location:
    Tucson
    Ratings:
    +2,371 / -3
    I went and re-examined the only log I saw in this thread (fourth post) and it all looks normal except for the fact that you've got almost no air flowing through the thing. Your AFRs are going super fat rich, which could be any number of things. The throttle goes wide open (76% is as open as it gets for the most part) and you're barely hitting 3v on the MAF which is ~85 g/s or 0.18 CFM. This is barely enough to cruise at highway speeds with. Either there's something blocking the intake of air (you don't have a trash bag wrapped around the air filter do you?) or there's something blocking the exhaust.
     
  9. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    From MazdaPros in Hollywood Fl i was told that my throttle body is not opening. They examined my throttle body plate compared to my throttle position and they said it doesn't open.

    So they told me "Hey we can replace the throttle body, and that should get it working." I paid them, they replaced it, no change. I also wanted to check my catalytic converter, i took it to a muffler shop. They used a vacuum gun? to check the vacuum in my engine and said that my catalytic converter was fine. Regardless, i did the "remove an o2 sensor" trick to see if it would relieve some back pressure, i did hear my turbo spool for that time, but when i tried to replicate that, i couldn't.

    I am now wondering, is my wiring messed up? Maybe the plug for my throttle body is bad? Anyways, if i remove my intercooler piping, and press on the gas should the throttle plate open? is it like drive by cable throttle bodies? or it wont move unless the engine senses load?
     
  10. Enki

    Enki Motorhead Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    1,523
    Trophy Points:
    113
    Location:
    Tucson
    Ratings:
    +2,371 / -3
    The throttle body has multiple redundant systems as is required by federal law (it's drive by wire) so any issue with it whatsoever would result in a check engine light. Also the throttle mapping when parked vs moving is completely different and your tune (yes your tune controls this) may be set to not let the throttle open much even with full pedal. In short, the shop that replaced your TB either was ignorant or lied. Did they ask you if you wanted the original TB? Does the one that's installed look brand new?

    Also depending on how bad the cat is, the symptoms may vary (or even be unreadable using the vacuum gauge method). I take it you never removed the downpipe and gutted it like you said you were going to also...? Another thing to keep in mind is that you may have enough exhaust flow to run normally but not enough to let the turbo breathe. If the turbo spins freely by hand (and has all the turbine wheel blades) it should, no matter what, make some boost regardless if the WG is open or closed (though if open might take more RPM / flow / load before it does make boost).

    Honestly you're all over the place with this thread and need to focus on one thing to absolutely verify; make a checklist of all the possible issues it could be in this thread, then doublecheck them yourself.

     
    • Like Like x 2
  11. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    You have a point. I have never done this, this is my first forced induction car, and so many components that i do not understand.

    I will make a checklist and start one by one, ruling things out as i go.

    I never got to actually remove the downpipe, so i am going to try that vacuum trick and remove it if necessary

    I'll start with this list:
    1. Catalytic Converter - Checking today when i get home.


    I'll add as i check them, and respond with what i find so it's more organized than before.
     
  12. Enki

    Enki Motorhead Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    1,523
    Trophy Points:
    113
    Location:
    Tucson
    Ratings:
    +2,371 / -3
    My point was that the vacuum trick might not work to diagnose your particular issue. It's a small ish engine with a relatively large exhaust, and larger turbos require a lot more airflow to get spinning. By all means, pull the downpipe and hollow it out and see if that helps, but if your exhaust is fully stock, you might have a clogged secondary cat as well or instead.
     
  13. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    Do you happen to have a picture of what the exhaust system looks like? I didnt know we had a secondary cat...
     
  14. Enki

    Enki Motorhead Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    1,523
    Trophy Points:
    113
    Location:
    Tucson
    Ratings:
    +2,371 / -3
    There's a downpipe, a mid pipe and a catback. The downpipe and midpipe have catalysts.
     
    • Like Like x 1
  15. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    Okay, not the catalytic converter. Removed, and emptied. No change. I can hear my turbo more now? Lol

    1. catalytic converter - Not it.
    2. Injectors????

    can injectors cause this issue? I was told if my injector seals go bad my engine won’t make boost. Don’t see how thats possible?
     
    Anthony Amador, via an iPhone, Sep 14, 2021
    #95
  16. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,811
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +2,340 / -13
    Which catalytic converter did you empty
     
    Easter Bunny, via a mobile device, Sep 14, 2021
    #96
    • Like Like x 1
  17. Enki

    Enki Motorhead Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    1,523
    Trophy Points:
    113
    Location:
    Tucson
    Ratings:
    +2,371 / -3
    [​IMG]
     
    • Like Like x 3
  18. Anthony Amador

    Anthony Amador Replacing this and that.. Silver Member

    Joined:
    Apr 7, 2021
    Posts:
    94
    Trophy Points:
    8
    Location:
    Miami, Florida
    Ratings:
    +18 / -1
    I used a rebar to empty the COBB, and the rear one was removed, and a pipe was welded on at an exhaust shop. So I no longer have any catalytic converters.
     
    Anthony Amador, via an iPhone, Sep 14, 2021
    #98
    • Like Like x 2
  19. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,811
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +2,340 / -13
    How dirty is your air cleaner?
     
    Easter Bunny, via a mobile device, Sep 15, 2021
    #99
  20. L337TurboZ

    L337TurboZ Master Technician Silver Member

    Joined:
    Jun 15, 2020
    Posts:
    420
    Trophy Points:
    63
    Location:
    Charleston, South Carolina USA
    Ratings:
    +394 / -4
    Do you have a muffler at all? If any of the converter material fell apart while the engine was running it is possible that it shot back into the muffler or a bent section of exhaust where it cant escape causing a restriction
     
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)