Mazdaspeed3 problem

Discussion in 'Mazdaspeed 3 Troubleshooting' started by Hunter, Dec 12, 2018.

Watchers:
3 users.
  1. Hunter

    Hunter Greenie N00B Member

    Joined:
    Nov 8, 2018
    Posts:
    8
    Trophy Points:
    1
    Location:
    Canada
    Ratings:
    +0 / -0
    Car starts up then dies after the rpms just drop and only way you can catch them is putting the gas in all the way anything less and nothing happens, anyone have any solutions, everything on the motor has been replaced everything is basically brand new ,wiring, fuses, relays.


    Sent from my iPhone using Tapatalk
     
    Hunter, via a mobile device, Dec 12, 2018
    #1
  2. CorkSport - Derrick

    CorkSport - Derrick Approved Vendor

    Joined:
    Feb 10, 2016
    Posts:
    508
    Trophy Points:
    93
    Location:
    Vancouver, WA
    Ratings:
    +685 / -0
    Unplug the MAF and see if the car idles...
     
  3. KingScumbag

    KingScumbag Gold Member

    Joined:
    Feb 10, 2016
    Posts:
    234
    Trophy Points:
    63
    Location:
    Taxachussettes
    Ratings:
    +290 / -0
    Codes? Mods? Tune? Did you ever solve the issue in your previous thread?
     
    KingScumbag, via a mobile device, Dec 12, 2018
    #3
  4. _Mazdarati

    _Mazdarati Silver Member

    Joined:
    Mar 13, 2017
    Posts:
    187
    Trophy Points:
    43
    Location:
    Dearborn, MI
    Ratings:
    +155 / -0
    We need more info. Mods, codes, etc.

    What is your HPFP pressure at idle? What are your AFRs? Fuel trims?

    Try getting a lot before it dies and we can try to narrow it down.
     
    _Mazdarati, via a mobile device, Dec 12, 2018
    #4
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)