Raider's P2187 on a 2007 Mazdaspeed 3

Discussion in 'Mazdaspeed 3 Troubleshooting' started by Raider, Sep 26, 2018.

Watchers:
9 users.
  1. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    My turn for the CEL that is random. Took a log until it came back on, then some shitty WOT logs. Any guesses what is wrong? 138K miles, stock downpipe with original O2 sensor, as well as factory MAF. So yeah, couple options to throw $ into it. Anyone able to see a problem based on the logs?
     

    Attached Files:

  2. neganox

    neganox Feline Führer Moderator Platinum Member

    Joined:
    Feb 9, 2016
    Posts:
    870
    Trophy Points:
    93
    Location:
    St Johns, FL
    Ratings:
    +1,599 / -4
    Uhhh.. Your LTFTs are like 17% while cruising and you have knock above 5k rpms. No bueno.

    oh and your AFRs are like 13.3 at WOT. That's not good.
     
    • Like Like x 2
  3. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    I have had high random knock forever. What can cause the 17% LTFT?
     
  4. Sho

    Sho Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    541
    Trophy Points:
    93
    Location:
    Akron, OH
    Ratings:
    +814 / -0
    Big vac leak or purge solenoid valve is bad.

    Like mentioned above,, you're super lean at WOT .
     
    Sho, via a mobile device, Sep 26, 2018
    #4
  5. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    Purge Valve Solenoid is blocked. Nothing getting through when I disconnected the hoses and did a suck blow test.
     
    Raider, via a mobile device, Sep 26, 2018
    #5
  6. Littleloogy

    Littleloogy Recovering Speed Addict Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    748
    Trophy Points:
    93
    Location:
    Ripon, CA
    Ratings:
    +1,066 / -0
    I hear you are good at that. I might have a valve laying around I can send you. Let me know.


    Sent from my iPhone using Tapatalk Pro
     
    Littleloogy, via a mobile device, Sep 26, 2018
    #6
    • Like Like x 3
  7. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    Haha! I got one. Hope it works. Logging idling and driving, will post. No WOT YET.[​IMG]

    Sent from my SM-G960U using Tapatalk
     
    Raider, via a mobile device, Sep 26, 2018
    #7
    • Like Like x 1
  8. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    OK, here are some logs. A couple idling and tapping gas, then when driving. It is noticeable that it does drive smoother overall.
     

    Attached Files:

    • Like Like x 1
  9. neganox

    neganox Feline Führer Moderator Platinum Member

    Joined:
    Feb 9, 2016
    Posts:
    870
    Trophy Points:
    93
    Location:
    St Johns, FL
    Ratings:
    +1,599 / -4
    LTFT is still terrible.
     
    neganox, via a mobile device, Sep 26, 2018
    #9
  10. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    Double checked MAF gasket had a nick in it. Then it snapped when removed. Had one in a bag, but I don't think it's flush. Going to probably replace it tomorrow. Ugh. [​IMG][​IMG][​IMG]

    Sent from my SM-G960U using Tapatalk
     
    Raider, via a mobile device, Sep 26, 2018
    #10
  11. Littleloogy

    Littleloogy Recovering Speed Addict Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    748
    Trophy Points:
    93
    Location:
    Ripon, CA
    Ratings:
    +1,066 / -0
    Well, It is broken... that much is clear.
    High LTFT at Idle/cruising (under Vacuum) makes me and everyone else think of a vacuum leak, sure. However, we need to keep in mind that under boost you are going lean also. Normally if, lets say your boost tube is jacked up, then it can suck air in under vacuum (Lean, High Trims) but also Loose air under boost (RICH AFR's). This makes me think that you have air getting into the system before the turbo, exhaust leak, or bad Primary o2 sensor.

    go smell your exhaust, take a big whiff but do not asphyxiate yourself!
     
  12. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    Exhaust has smelled fuelly and nasty forever. Intake is all tight, too checked hoses, map sensor bolt, OCC is closed.
     
    Raider, via a mobile device, Sep 26, 2018
    #12
  13. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    Well there is a downpipe bolt that has been ejected. Missing a nut on the manifold now too. Ugh. [​IMG]

    Sent from my SM-G960U using Tapatalk
     
    Raider, via a mobile device, Sep 26, 2018
    #13
  14. neganox

    neganox Feline Führer Moderator Platinum Member

    Joined:
    Feb 9, 2016
    Posts:
    870
    Trophy Points:
    93
    Location:
    St Johns, FL
    Ratings:
    +1,599 / -4
    Probably a bad O2. 100k+ miles is a fuck ton for any sensor.
     
  15. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    Back in the day, Amazon had em for 60 bucks. Looking like 120 or so now. Fuck.

    Sent from my SM-G960U using Tapatalk
     
    Raider, via a mobile device, Sep 26, 2018
    #15
  16. neganox

    neganox Feline Führer Moderator Platinum Member

    Joined:
    Feb 9, 2016
    Posts:
    870
    Trophy Points:
    93
    Location:
    St Johns, FL
    Ratings:
    +1,599 / -4
    Primary sensors are $$$. Secondaries are cheapo.
     
  17. Littleloogy

    Littleloogy Recovering Speed Addict Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    748
    Trophy Points:
    93
    Location:
    Ripon, CA
    Ratings:
    +1,066 / -0
    There is your exhaust leak. I bet if you replace the missing bolt everything will balance out. If it is a shit aftermarket paper-metal gasket you might have to replace the gasket, if you had one bolt back out you can bet that another may have as well.

    My cousin had an exhaust leak similar to that. Exhaust was pig rich as well. We ended up smoking the exhaust to find that there were a few loose bolts on his DP. Tightened it up, all was good.


    Sent from my iPhone using Tapatalk Pro
     
    Littleloogy, via a mobile device, Sep 26, 2018
    #17
  18. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    I'm probably going to have my techs at work install these tomorrow. Can't be going lean at all. That's bad. I will also check out oem oxygen sensor too. My money is that it was cross threaded in. Because everything on my car is a bitch.

    Sent from my SM-G960U using Tapatalk
     
    Raider, via a mobile device, Sep 26, 2018
    #18
    • Like Like x 1
  19. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    3,823
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +4,658 / -3
    So much for that, they want 8 hours labor. So looks like my Sunday is going to be fun. Edit, nope, family plans. Now I don't know when, maybe next Wednesday. Fuck.

    Sent from my SM-G960U using Tapatalk
     
    Raider, via a mobile device, Sep 27, 2018
    #19
  20. neganox

    neganox Feline Führer Moderator Platinum Member

    Joined:
    Feb 9, 2016
    Posts:
    870
    Trophy Points:
    93
    Location:
    St Johns, FL
    Ratings:
    +1,599 / -4
    I'd say put on the missing nuts, tighten up the exhaust, and reflash your last map to clear your learned trims out. Who knows how long you've been driving around like this. After you flash then check out the STFTs to see if they go into the teens.

    Pretty sure CS provided metal gaskets when we installed that turbo.
     
    • Like Like x 5
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)