What did you do to your ride today

Discussion in 'Mazdaspeed 3 General Discussion' started by CmdrShepard, Feb 13, 2016.

Watchers:
107 users.
  1. ToyCop

    ToyCop Greenie Member

    Joined:
    Jun 1, 2016
    Posts:
    217
    Trophy Points:
    43
    Location:
    Michigan
    Ratings:
    +149 / -0
    Just sucks I have to replace the bumper cover. The paint will likely never match.
     
    ToyCop, via an iPhone, Jul 13, 2019
  2. SeeMeGovan

    SeeMeGovan Greenie Member

    Joined:
    Apr 21, 2016
    Posts:
    24
    Trophy Points:
    13
    Location:
    Seattle, WA
    Ratings:
    +27 / -0
    Can confirm, both my bumpers, my hood and 2 of my doors are a slightly different shade of silver than the reset of my car.

    Sent from my LG-H918 using Tapatalk
     
    SeeMeGovan, via a mobile device, Jul 14, 2019
  3. ToyCop

    ToyCop Greenie Member

    Joined:
    Jun 1, 2016
    Posts:
    217
    Trophy Points:
    43
    Location:
    Michigan
    Ratings:
    +149 / -0
    Finally washed it again. Going in for the body work on the 12th. Shop is confident they will get a good paint match.

    094F8864-C6A2-427D-8E2C-87CDAFC50B99.jpeg
     
    ToyCop, via an iPhone, Aug 2, 2019
  4. ToyCop

    ToyCop Greenie Member

    Joined:
    Jun 1, 2016
    Posts:
    217
    Trophy Points:
    43
    Location:
    Michigan
    Ratings:
    +149 / -0
    Car is back from body shop. I think they did a great job. I think I’m going to leave the silver fog rings and chrome emblem this time. Need to polish my headlights.

    3B6470DF-B840-487B-B36B-D6848290101D.jpeg FA9D7528-97A9-4527-9162-8C5874B33B3E.jpeg
     
    ToyCop, via an iPhone, Aug 21, 2019
    • Like Like x 1
  5. ZachS.

    ZachS. Greenie Member

    Joined:
    Aug 30, 2016
    Posts:
    25
    Trophy Points:
    3
    Location:
    US
    Ratings:
    +5 / -0
    Installed front and rear TB Performance tie bars and a GFB Bov/Bpv. The car seems to handle better and possibly have less understeer. Bov sounds great, it’s set about 50/50 and I do get a little pop out of the exhaust on shifts every once in a while.

    [​IMG]

    [​IMG]

    [​IMG]


    Sent from my iPhone using Tapatalk
     
    ZachS., via a mobile device, Sep 15, 2019
    • Like Like x 1
  6. macdiesel

    macdiesel Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    331
    Trophy Points:
    63
    Location:
    Kenosha, Wi
    Ratings:
    +281 / -0
    Good times

    23100EF3-7321-4FC3-9A5B-2DC721164512.jpeg
     
    macdiesel, via an iPad, Sep 15, 2019
  7. Faeker

    Faeker Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    156
    Trophy Points:
    43
    Location:
    Reading, pa
    Ratings:
    +244 / -2
    Protip: dont break shit lol

    Sent from my LM-V405 using Tapatalk
     
    Faeker, via a mobile device, Sep 15, 2019
    • Like Like x 1
  8. macdiesel

    macdiesel Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    331
    Trophy Points:
    63
    Location:
    Kenosha, Wi
    Ratings:
    +281 / -0
    OEM outer tie rod lasted over 120k, which made it a mother to get off. Out came the cutting wheel.
     
    macdiesel, via an iPhone, Sep 15, 2019
  9. Faeker

    Faeker Greenie Member

    Joined:
    Feb 10, 2016
    Posts:
    156
    Trophy Points:
    43
    Location:
    Reading, pa
    Ratings:
    +244 / -2
    Ball joints are a bitch toobat that age. Do it all at once.

    Sent from my LM-V405 using Tapatalk
     
    Faeker, via a mobile device, Sep 15, 2019
  10. macdiesel

    macdiesel Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    331
    Trophy Points:
    63
    Location:
    Kenosha, Wi
    Ratings:
    +281 / -0
    Yup, luckily I swapped lca’s ~50k ago to Moogs. This was easier than cutting the inner tie rod.

    D570130C-EDA1-4519-B6AC-070A5914206E.jpeg
     
    macdiesel, via an iPhone, Sep 15, 2019
    • Like Like x 1
  11. Awafrican

    Awafrican Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    1,178
    Trophy Points:
    113
    Location:
    Ontario, Canada
    Ratings:
    +917 / -3
    Swapped my OEM Bpv back on, seems to be holding boost better than my forge v2, bummer as I liked the sound
     
    Awafrican, via a mobile device, Sep 15, 2019
    • Like Like x 1
  12. Awafrican

    Awafrican Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    1,178
    Trophy Points:
    113
    Location:
    Ontario, Canada
    Ratings:
    +917 / -3
    Moving to Manitoba next week so a block heater was installed. all I have to say is fuck you 1st exhaust stud. Mazda instructions say remove #1&2 on the back left to get access for tools. I've seen guides say just #1 which I'd agree to. Since mine wouldn't come out I did it with them in...2 clicks at a time FML. Anyway it's done.

    Edit: while having the under tray off I noticed a weird rub on the oil pan, not sure what from.
     

    Attached Files:

    Last edited: Jan 14, 2020
    Awafrican, via a mobile device, Jan 14, 2020
    • Like Like x 2
  13. Littleloogy

    Littleloogy Recovering Speed Addict Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    791
    Trophy Points:
    93
    Location:
    Ripon, CA
    Ratings:
    +1,144 / -0
    What a pain in the ass. Perseverance should be your middle name!

    Weird indeed. Was that from someone using your oil pan as a jack point?



    Sent from my iPhone using Tapatalk Pro
     
    Littleloogy, via a mobile device, Jan 14, 2020
    • Like Like x 1
  14. Awafrican

    Awafrican Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    1,178
    Trophy Points:
    113
    Location:
    Ontario, Canada
    Ratings:
    +917 / -3
    Lol yeah it was a PITA. But I had already cracked the seal so no going back...

    Umm I'm not sure unless a shop has because I never jacked it there and I'm the only owner. It's been at 2 different dealerships, one auto body, and that's it. most of my lifting is done on a hoist as I've had access to one for 5 years now.

    I'm leaning towards perhaps the under tray rubbing in a weird way? This clearly isn't new I cleaned it up for the pic. I cannot recall if it was there when I replaced the OEM tray for a cheap Amazon one when it does.
     
    Awafrican, via a mobile device, Jan 14, 2020
  15. macdiesel

    macdiesel Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    331
    Trophy Points:
    63
    Location:
    Kenosha, Wi
    Ratings:
    +281 / -0
    I hope you had a good ratchet were clicks matter.



    Sent from my iPad using Tapatalk
     
    macdiesel, via a mobile device, Jan 15, 2020
    • Like Like x 2
  16. Awafrican

    Awafrican Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    1,178
    Trophy Points:
    113
    Location:
    Ontario, Canada
    Ratings:
    +917 / -3
    I sure do, learnt that one early on
     
    Awafrican, via a mobile device, Jan 15, 2020
    • Like Like x 2
  17. Awafrican

    Awafrican Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    1,178
    Trophy Points:
    113
    Location:
    Ontario, Canada
    Ratings:
    +917 / -3
    Day 2: oil change, coolant flush and JB welded that scuff on my oil pan. Can confirm its from the undertray rubbing. Stupid Amazon part as a metal bar in the back for ridgidy and it was bent up so that was rubbing on my oil pan. Smacked that down with a hammer plenty of space now.

    Oh and I also rotated my tires, lubed all my door hinges and shifter.
     
    Awafrican, via a mobile device, Jan 15, 2020
  18. macdiesel

    macdiesel Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    331
    Trophy Points:
    63
    Location:
    Kenosha, Wi
    Ratings:
    +281 / -0
    Dazzled up them Walmart hubcaps with some Mazda flare.

    62769290-D9E6-4F5A-88BF-6F859D6E379B.jpeg
     
    macdiesel, via an iPad, Jan 17, 2020
    • Like Like x 2
  19. Awafrican

    Awafrican Gold Member

    Joined:
    Feb 11, 2016
    Posts:
    1,178
    Trophy Points:
    113
    Location:
    Ontario, Canada
    Ratings:
    +917 / -3
    Sploosh
     
    Awafrican, via a mobile device, Jan 17, 2020
    • Like Like x 4
  20. Anaphra

    Anaphra Greenie Member

    Joined:
    Feb 27, 2020
    Posts:
    12
    Trophy Points:
    3
    Location:
    Chico CA for School, Originally from the Bay Area
    Ratings:
    +12 / -0
    IMG_1578.JPG IMG_1586.jpg I somehow broke the lower coil on my rear right side coil spring the other day, finally got both the rears swapped out for OEM.

    On another note selling MS3 2 peace OEM rear springs /s
    165k miles
     
    Last edited: Mar 3, 2020
    • Like Like x 2
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)