Car won’t start

Discussion in 'Mazdaspeed 3 Troubleshooting' started by Lucky Edouard, Feb 11, 2020.

Watchers:
6 users.
  1. Lucky Edouard

    Lucky Edouard Greenie N00B Member

    Joined:
    Feb 11, 2020
    Posts:
    2
    Trophy Points:
    1
    Location:
    Florida
    Ratings:
    +0 / -0
    Hey guys I’m kinda new to this. I recently got my car fixed from polarizing the battery and shorting the car. Then recently the car was taking a while to turnover til it just couldn’t crank anymore so I thought it was the plugs so I replaced them. Car still won’t start so I’m stuck now.


    Sent from my iPhone using Tapatalk
     
    Lucky Edouard, via a mobile device, Feb 11, 2020
    #1
  2. Maisonvi

    Maisonvi Silver Member

    Joined:
    Feb 10, 2016
    Posts:
    1,381
    Trophy Points:
    113
    Location:
    South Haven, MI
    Ratings:
    +1,931 / -0
    Check your battery. First and easy thing to look at and could be a simple fix. If thats not it, then we can dig deeper
     
    • Like Like x 2
  3. Raider

    Raider Administraider Administrator Platinum Member

    Joined:
    Jan 28, 2016
    Posts:
    5,170
    Trophy Points:
    113
    Location:
    Behind a Keyboard wearing full body armor
    Ratings:
    +6,241 / -4
    Totally sounds like a battery
     
    Raider, via a mobile device, Feb 12, 2020
    #3
  4. Sho

    Sho Gold Member

    Joined:
    Feb 10, 2016
    Posts:
    1,026
    Trophy Points:
    113
    Location:
    Akron, OH
    Ratings:
    +2,006 / -0
    Slow/long crank ending up with no crank sounds like a dead battery
     
    Sho, via a mobile device, Feb 12, 2020
    #4
    • Like Like x 2
  5. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,151
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +1,733 / -6
    what happens when you turn the key, does it go through the normal startup routine and just wont turn the motor?
     
  6. Lucky Edouard

    Lucky Edouard Greenie N00B Member

    Joined:
    Feb 11, 2020
    Posts:
    2
    Trophy Points:
    1
    Location:
    Florida
    Ratings:
    +0 / -0
    Yea it does that.


    Sent from my iPhone using Tapatalk
     
    Lucky Edouard, via a mobile device, Feb 12, 2020
    #6
  7. Littleloogy

    Littleloogy Recovering Speed Addict Platinum Member

    Joined:
    Feb 10, 2016
    Posts:
    799
    Trophy Points:
    93
    Location:
    Ripon, CA
    Ratings:
    +1,166 / -0
    If your battery checks out okay (auto parts store can do a load test on it) then I would think it is the stater itself.

    Last year my car struggled to start. I thought it was my battery since I noticed an improvement if I had a charger on it. But over time it got slower and slower. As it was wearing out it would draw more and more amps. I picked me up a new aftermarket starter off amazon. Fixed my issue.


    Sent from my iPhone using Tapatalk Pro
     
    Littleloogy, via a mobile device, Feb 12, 2020
    #7
    • Like Like x 3
  8. Easter Bunny

    Easter Bunny Professional Engineer Platinum Member

    Joined:
    Feb 11, 2016
    Posts:
    1,151
    Trophy Points:
    113
    Location:
    Earth
    Ratings:
    +1,733 / -6
    Also check the power wore to the starter. They are a known problem on these cars

    edit: wire
     
    Last edited: Feb 13, 2020
    Easter Bunny, via a mobile device, Feb 13, 2020
    #8
    • Like Like x 3
Loading...

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)